Thomas P.

Synology, Agent run out of system notify watchers, some internal tasks are taking too much time to complete

Recommended Posts

Dear Synology,

Resilio worked over the years properly to sync my Synology DS415play against my Synology 414pro.

Once a time i have to make an update because files over 3GB where not synched. I think it was 2.6.2. This version work for a while until the DS415play always lost connection to the other nas.

I installed every update, also the latest, but it doesn´t change anything.

If i synch only 4 small shares (pictures, data, music, cloud) everything is fine. If i add the 5th (movies) or 6th share (backup), which includes many big files, everytime the connection is lost in between the both NAS.

 

The ds414 reports every time "Agent run out of system notify agents. Updated files will be uploaded only after periodic folder scan"

The ds415 seems to be slow like hell and should be the reason, why the connection is always lost. When i try to reach the web gui, des Password is prompted very quick, but than it takes very long to bring me the informations to the screen. i have over minutes a blank white screen. The error log often displays "Some internal tasks are taking too much time to complete".

In former versions on both systems i always see that both had 1of1 peers, today it is 1of1 than 0of1 after a while 1of1, than 0of1.

Question: what seems to be wrong? You said, you are the best system to synch million of files.

In the meanwhile i delete all resilio share, deleted all synch folders, install v2.6.2, install 2.7.x, nothing work anymore properly.

best regards
Thomas

Share this post


Link to post
Share on other sites

Dear All,

it seems to be, it was the max_user_instances (128->1024) and max_user_watches (8192->65536).

At the moment i will not receive error message, but NAS goes offline again

Share this post


Link to post
Share on other sites

@DS415play the log is complete full of detect stuck job lines.

 

[20200802 14:15:49.368] Detected stuck job[0x97717c98]: ReadStreamsJob

[20200802 14:15:49.487] Detected stuck job[0x9968f3c8]: ReadStreamsJob
[20200802 14:15:49.487] Detected stuck job[0x9b547458]: ReadStreamsJob
[20200802 14:15:49.536] Detected stuck job[0xa2a0db80]: ReadStreamsJob
[20200802 14:15:49.562] Detected stuck job[0xa2a113b0]: ReadStreamsJob
[20200802 14:15:49.562] Detected stuck job[0xa35cd8d0]: ReadStreamsJob
[20200802 14:15:49.572] Detected stuck job[0xa35e2db8]: ReadStreamsJob
[20200802 14:15:49.572] Detected stuck job[0xa9b6a190]: ReadStreamsJob
[20200802 14:15:49.573] Detected stuck job[0xaccb29b0]: ReadStreamsJob
[20200802 14:15:49.573] Detected stuck job[0xaccc7550]: ReadStreamsJob
[20200802 14:17:04.193] Detected stuck job[0x97c67e40]: ReadStreamsJob
[20200802 14:17:04.291] Detected stuck job[0x9c104e88]: ReadStreamsJob
[20200802 14:17:04.291] Detected stuck job[0x9ca56238]: ReadStreamsJob
[20200802 14:17:04.291] Detected stuck job[0xa1e98da0]: ReadStreamsJob
[20200802 14:17:04.291] Detected stuck job[0xa2a06160]: ReadStreamsJob
[20200802 14:17:04.291] Detected stuck job[0xa35e47c8]: ReadStreamsJob
[20200802 14:17:04.292] Detected stuck job[0xa9b10b88]: ReadStreamsJob
[20200802 14:17:04.292] Detected stuck job[0xacc67588]: ReadStreamsJob
[20200802 14:17:04.292] Detected stuck job[0xacc73468]: ReadStreamsJob
[20200802 14:17:04.292] Detected stuck job[0xaccc6ec8]: ReadStreamsJob                                                                                                                              

How can i fix this.....

Share this post


Link to post
Share on other sites

Maybe is better

On 7/23/2020 at 7:11 PM, Thomas P. said:

my Synology DS415play against my Synology 414pro

 

Both DS have 1 GB RAM and a part of it is used by the system. So the question is, how much folders and files are managed from Resilio.

 

On 7/23/2020 at 7:11 PM, Thomas P. said:

both had 1of1 peers, today it is 1of1 than 0of1 after a while 1of1, than 0of1

 

This is maybe more a performance problem of the network to the external Internet. If you have problems with the Internet connection, this could be the effect, since Resilio need the Internet connection to contact the peers between the different devices, even there are in the same LAN.

Share this post


Link to post
Share on other sites

Dear Andi,

just find out, that the clamav engine was the problem at the 415play.
Until the moment i deinstalled it, resilio work like before.

I don´t know why, but it work years before and it only makes a system scan.
Both NAS are on the same software, strange.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.