IgnoreList - lines beginning with #

Recommended Posts

It appears that lines beginning with "#" would be skipped when parsing the IgnoreList, since at the top we have lines like

# IgnoreList is a UTF-8 encoded .txt file that helps you specify single files, paths and rules
# for ignoring during the synchronization job. It supports "?" and "*" wildcard symbols.

But, in the default IgnoreList for new folders, these 3 lines also exist (seems related to Synology Drive app):


I am assuming that this is either a mistake, or somehow this isn't working because I guess these lines would be "ignored by the IgnoreList itself"¬†ūü§Ē

Link to comment
Share on other sites

  • 2 months later...

In the Linux world it is standard that script lines with # at the beginning is a character for commenting out. Everything that follows a # is at most a comment, nothing else. And it doesn't matter whether there is a space after it or not. Sometimes // are also used, but this is not common.

# are not errors, but give the user the choice, e.g. activate or deactivate a parameter etc.

More about the IgnoreList here


Link to comment
Share on other sites

  • 7 months later...

I've come across this, however if you read the document on here it says only lines that begin with # are treated as comments. It also states that entries can include a path. So for a Synology NAS, I simply changed the entry from #snapshot to /#snapshot - which is fine, as that directory is always in the root of the shared folder. Seems to work ... it's just a pain that you have to copy an updated "IgnoreList" file to each new folder - you can't set it as a default within ResilioSync, so it will always use its' defaults when it starts syncing a new folder unless you manually create the .sync subfolder and copy your updated "IgnoreList" file to it before initiating the sync.

Link to comment
Share on other sites

  • 2 months later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.