0% progress after hours


Recommended Posts

I have two computers in the same room, connected to the same network. Both of them see the other in Resilio Sync. Both of them say "0% progress" for several hours now.

I have restarted RS on both of them. Both are running version 2.7.2.

So… now what do I do?

 

Link to post
Share on other sites
  • 1 month later...

I have the same issue  (on certain tasks)) This needs fixing !!

i run this on 3 machines.

Two docker instances on machine 1 running unraid both from different repos (they each handle half of my data because I run out of watchers (separate issue that also needs fixing)

Machine 2 is the synology that receives everything..

Machine  3 Is a Windows PC

 

All 3/4 Have the Issue.

All 3 machines AUTO update to the latest STABLE and ii don't know how to downdate especially with unraid or synology also they would just auto update again.

 

I'v been battling this for aa while and have removed the sync folder unpaired and removed the tasks and uninstalled the apps.

It is just broken. (but only on some tasks) 

The task that sync's my Retro Game Roms and the task that syncs my Program data wont sync  but media has been unaffected.  

 

Link to post
Share on other sites

Maybe the problem has to do with Synology’s partly strange ACL system. In my opinion maybe this have nothing to doe directly with Resilio. However, in most cases I can remove such things with a standard procedure.

In such cases, I’ve deleted the Synology ACLs by setting the owner and group to root and octal rights to 0777 for all files and subdirectories in the affected peers. Then I go back to Synology DSM into filestation and inherit the permissions again in these peers in all files and subdirectories.

This is kind of a standard procedure if I have any kind of permission issue. But I outline, is also a procedure more for experts and people, which know the background of such things.

Link to post
Share on other sites

i don't know how to do that but i've been trying.

before i go any further I'll test syncing to the windows pc only.  (synologgy removed from equation)

Unraid has a permission utility so that defines what it's set to ( 000  user / group nobody i think )

 

(yyou'll have to fforrgive mme if i come accross as foul tempered .. My keybord iis not working ccorectly  aas this text shows ((very frustrating to type))

 

if pc works i'll try again tto do as you say.

Thanks,, Mat

Link to post
Share on other sites

In synology they seem tto be check box. (allow permission yes or no with no mention of a octalal

i'll play with the idea for a bit and see what happens

It may have coincided with a large number of Amiga Roms hitting the system so permissions is a good shout.

 

Its been working this way for 6 years now so it seems strange  

Link to post
Share on other sites

Could you walk me through what ever your saying  (google has no reference to synology acl only windows acl)

well i've done everything i can do to make the permissions workable.

there were permissions problems in windows they are now ok..

IIn synnology i've given rslsync permission as a system internal user and checked all advanced permission options look correct.

i don't see anyway to do what your saying.

I didnt yet try with out the synology paired (i wanted to see if i could figure out what you were saying first)

But obesely that wouldn't fix anything just help me find what system is at fault

Link to post
Share on other sites

windows has the same issue even just between windows and unraid

permissions in windows are set to "everyone" and "full control" manually for all files

but it wont index 

I'm going to try Synology's DS Cloud app instead to just to see what happens.

this has been going on for weeks now sometimes it go's to 1% and I've seen it stuck as high as %20 but normally %0 and at the moment it go's between 0-1 then back to 0

 

Update DS Cloud (now called Drive (shows how long i've been using Resillio)) seems to be unaffected.

I'll see if i can use it to juggle the files onto the unraid system and tidy the permissions up  from there but it's not looking like a synology issue to me.

This might take a few days because it will re introduce the 60k duplicates with different names i was trying to remove when Resilio fell over all of witch all probably have bad permissions..

 

once that is done IF it still wont sync I'm going to need a fix

Link to post
Share on other sites

so my current work around goes like this. 

Synology drive takes files from the pc to the synology and back then from the  synology drive moves them to a VM where Resilio is then (magically) able to work with them again and move them into to the unraid drives.

I'm hoping once i get all the conflicts that this will generate resolved i can fix the permissions and go back to a 3 way sync.

But for now apart from being slow (and silly) it seems to work

I should not need to spin up a VM just to handle this ( i guess i could try vm straight to pc but that doesn't really stop me having the VM or get stuff onto the synology)

Link to post
Share on other sites

As tools I use the Synology Filestation and WinSCP

https://winscp.net/eng/download.php

On 10/10/2020 at 11:12 AM, Andy+ said:

I’ve deleted the Synology ACLs by setting the owner and group to root and octal rights to 0777 for all files and subdirectories

look at "https://winscp.net/eng/docs/screenshots" dwon to "Changing Properties of Files and Folders" to see the menu to set the above.

Link to post
Share on other sites
  • 2 weeks later...

so  create a user called root?

what even is an octal anyway?

winscp just as well be written in Klingon because it makes no sense to me. 

i can't see any reference to octal in the synology at all.

I've managed to get the number of effected files to 1650 and the permissions of them look different to other files when viewed with windows explorer.

I can't understand how Resilio managed to move the files to it but now can't do anything with them, yet the other 25TB is not effected.

no files have root present as a user not even the good ones

The user of the good files is rlsync  (makes sense i guess and it works) (the synology has 1 job and that is sync files with Resilio so the only thing effect by user  group or whatever an octal is, is Resilio)

File station can't actually view folder that the files are in because there are two many files (60,000 ish) and working on the parent folder helped a bit but for whatever reason didn't touch these.

I've got windows taking another pop at um at the moment then i might try deleting them and resyncing the entire share (3TB) (when that fails i'm out of ideas)

I've go a few other ways to attack it unless anyone can off some clear instruction or better yet a fix that involves the software doing what it's supposed to.

Link to post
Share on other sites

The user "root" is the root user on every Linux system and thus a standard user, which is usually not visible.

Octal is a mathematical expression for certain types of numbers. In Linux there is the rwx system for the permissions and every file and every directory is provided with it. The number 7 means rwx and the number 777 means rwxrwxrwx, so full permissions for everyone in this case. 000 would therefore be - - - - - - - - -. Further details can be found on the Internet.

What I am suggesting here is one of my methods of dealing with such situations. Of course, it can also be resolved in another way, but I don't know of such other ways.

It is also clear that every software or user leaves corresponding entries, this is completely normal, so "root" cannot be written there, since root doesnt work usually. However, the methodology is about alignment in order to have a functioning basis.

The adjustment in the filestation is done via the corresponding directory name in the directory tree on the left.

Link to post
Share on other sites

Thank you for the explanation.

As you've stated root is not always visible to the user.

I've been through file station permissions that's how %90 of it was fixed already but no way of setting root (that would be to easy wouldn't it lol)

I'm definitely indexing now so we're moving again. (Hopefully)

I'll know more in a few days

(the synology only has an atom cpu)

Hopefully that's done it.

You don't have to answer this one but maybe a script that ran the chown command every day or something would prevent this.

I'll look into that

 

Thanks

Link to post
Share on other sites
1 hour ago, mdrodge said:

an atom cpu

Which type you use? I have DS1815+, DS415+, DS412+ all also with such CPU type.

Important is also the volume to sync. Each file, each folder needs 0,8-1 kB of RAM to manage that. In my Synologys with 16 GB of RAM I manage with Resilio round about 1.200.000 files, 90.000 folders, 2,4 TB of Data. This means approx. 1 GB of RAM, in reality its 1,04 GB.

So, maybe is to much of all on your Synology.

Link to post
Share on other sites

I tried that. (Might give it another go when I'm sure all files are ingested)

I definitely need to fix the permissions.

I'm still working on it slowly.

I'm making sure all files are ingested first then hopefully I can fix them.

It's just 1 share of retro game roms now the rest of my library is done working as normal.

 

I'm using the synology software for that one folder.

(Once it's synced it's unlikely to change again anyway so no real worries anymore.)

Thanks though. :)

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.