Pi Zero W Raspbian Buster : "Not enough free space"


Recommended Posts

Hi,

I'm running Resilio Sync (pro license) just fine on a bunch of stuff

  • Via the "jail" plugin on my FreeNAS (11.2)
  • 6 x installs on Ubuntu 20.04 (Intel and AMD and laptops and desktops)
  • 4 x installs on Raspbian Buster on RPi 3 and 4B (running either armhf or aarch64)
  • 1 x install on Armbian (Xenial) on an Orange Pi+ 2E
  • 2 x install on Debian Jessie on NTC CHIP (including PocketCHIP)
  • 1 x install on Windows 10 "corporate" laptop

But I'm stumped if I can get it working on Raspbian Buster on a Pi Zero W...  

First snag I hit was the binary / systemd backend wouldn't even start (issue with binary "rslsync") - so I did the workaround (got the armhf tar file and cp'd the binary to /usr/bin/rslsync).  That got me over one hurdle.

But now EVERY time I try to setup a sync folder - I get status "Not enough free space on the drive."  - I've got a sh!tload of free space, it's headless debian on a 128 GB SDcard!  I've seen (via google-fu) other uses have the same problem on Raspbian (some on Zero, some on 3B board), but this ONLY happens to me on Raspbian buster armhf running on Pi Zero W (I've gone the whole route of flashing a new image twice now - and hit the same wall).  This is my first Pi Zero board...

Anyone know a fix for this?

Link to post
Share on other sites

May be this helps

 

On 11/9/2020 at 10:06 AM, Daria said:

 

 

Please set disk_min_free_space parameter to 0 in Power user preferences (Preferences > Advanced > Open power user preferences). Restart Sync to apply the change.

 

1 hour ago, manudoteu said:

In fact, I have the same problem about running low on space, whereas it is not the case.

And disk_min_free_space is already set to 0 in my configuration. But I don't find any disk_check_free_space  in the settings.

 

So, it would be good to check the above parameters or to run really with default settings.

Link to post
Share on other sites
2 hours ago, Rmv said:

Hello,
The problem seems to be solved for me by following the instructions from Daria set disk_min_free_space parameter to (by default 0.0). Thanks a lot.

 

Maybe this helps.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.