Unable to access WebUI from another PC (Linux host)


Recommended Posts

Hey guys,

I just freshly setup Resilio on a PC running CentOS stream. I can access the web interface on the same PC with https://localhost:8888/ but not from another computer

I have made sure that the firewall has tcp port 8888 open (it should work, I have another service running, opened the firewall and there it works as well).

Any idea what I can check to fix this matter? Is there any setting that needs to be set to access the webUI from another computer?

thanks

Link to comment
Share on other sites

Hi, thanks for the help.

My config file has that already:

 

  "webui" :
  {
    "listen" : "0.0.0.0:8888" // remove field to disable WebUI

This was there without me adding it.

Should that be enough?

I am a bit confused because the export of the config file does not seem to match 100% the actual settings in the client, e.g. I disabled uPnP but it's ON in the config that was exported.

Link to comment
Share on other sites

Yes it's enough. Next you should use netstat to verify the rslsync is really listening to port 8888 on all interfaces:

netstat -anp

if it indeed listens on all interfaces, then I guess it's firewall,  try totally disable firewall (temporally) and test.

Link to comment
Share on other sites

On 3/3/2021 at 9:16 PM, uncovery said:

Thanks for the advice. I get this line in netstat:

 


tcp        0      0 127.0.0.1:8888          0.0.0.0:*               LISTEN      -

I stopped firewalld, but it still does not work.

The line from netstat clearly shows your rslsync is listening to 127.0.0.1:8888, which is only accessible from localhost.

For listening to all interfaces, It should be like:

tcp        0      0 0.0.0.0:8888          0.0.0.0:*               LISTEN      -

There might be some problems with your config file, try testing rslsync with --webui.listen option as

./rslsync --webui.listen 0.0.0.0:8888

see:

Guide to Linux, and Sync peculiarities – Sync (resilio.com)

 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share