Agent Install on TrueNAS error: <no Python frame>

Recommended Posts

After inputting command from the install instructions here:


This issue occurs:


'Current thread 0x0000000800a42000 (most recent call first):

<no Python frame>

Fatal Python error: init_sys_streams: <stdin> is a directory, cannot continue

Python runtime state: core initialized'


The other response I have gotten when trying to input different pool names is "zsh: no such file or directory"


I was told it may be due to an invalid value of PYTHONPATH set in the system. To resolve, unset the value of this environment variable using the following command "unset PYTHONPATH" Unfortunately I'm not able to do so, I may be doing something incorrectly...I have tried unsetting via 'unset /usr/bin/python' but was shown 'invalid parameter name. I also tried export PYTHONPATH then unset to try to reset but to no avail. I am still learning so may have very well missed something but if any ideas and links to learning materials in this regard would be much appreciated!


Thank you!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.