Resilio Sync crashes on Android after about 1 second. How to get the logfiles?


H.P.
 Share

Recommended Posts

Hi!

I currently have the problem that Resilio Sync crashes on my Android (7.1.1, Nokia 7) Handy about one second after I start it, after having worked faithfully for years. Unfortunately the crash is so quick, that I cannot report the problem via the menu. It also doesn't show any "Application has crashed" screen - it looks like it just finishes itself. What to do?

I had enabled the debug log, but I'm not able to find it with a file explorer. Where is that file saved?

BTW: I think the problem is related to long file / directory names and / or unusual characters in file names. This started happening shortly after I introduced some new files with pretty long names which also contained characters like ' . But it doesn't go away now even when I remove that folder or the toplevel folder via a file manager. I also removed those files from the peers, but that doesn't help.

Thank you so much!

Hans-Peter

Link to comment
Share on other sites

Thank you, yes, I hope deleting everything and setting it up again would work, but I still hope someone can point me to the log files, since it'd be nice if I could report that bug to Resilio, as it's actually not the first time I encountered that. It's not nice when the app just finishes itself, without any way to find out what the problem is or to report it.

Best regards,

Hans-Peter

Link to comment
Share on other sites

  • 1 year later...

A pointer where to find this mysterious "database" might be helpful...  I've hit the same issue...

Tried to add a new sync folder to my S9+ running Android 10, and it kept hanging... So I removed ALL my sync folders off the device... removed the app..

Re-installed the app, now it just crashes about 5 minutes after I scan a QR code...   And the sync folder is called "Music" and somehow, despite removing that sync folder, and Resilio Sync, completely (apart from this mysterious "database"), the folder still shows up on the Android side as Music(1) - which means that RSL has still got some hooks somewhere in my Android system, to that name... And no - I don't want to rename it...  Note also - I can't change anything whatsoever in RSL on Android, it pretty much just hangs when I try to sync that folder...  

It works pretty much flawlessly everywhere else, my iPad Pro running 15.6, my MacBook Pro M1, both my main Linux desktop machines, and my work MacBook Air (and when I still had a work Windows machine - it all worked swimmingly there too)...  Why the glitches on Android?  

If I wait a further 10 minutes after it stops responding, Android popups up a thing about unresponsive app and offers to let me kill it, or wait...  Makes no difference which I choose, it's UNUSABLE!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share