Resilio-sync.service "deactivated successfully" after start [SOLVED]


culebrón
 Share

Recommended Posts

I run Resilio in Ubuntu 21.10, that I installed yesterday. Resilio is installed from the official repository.


I used this configuration for months, but now Resilio stopped runinng. It starts normally for a few seconds, then exits.

(I did `systemctl enable resilio...` before this)

sudo systemctl restart resilio-sync.service
sudo systemctl status resilio-sync.service

Initially it shows status as running, but after 3 seconds I see this:

окт 16 23:40:19 asus systemd[1]: Started resilio-sync.service.
окт 16 23:40:22 asus systemd[1]: resilio-sync.service: Deactivated successfully.

All the advice you can find on the Internet is about tweaking Resilio through its web UI on Windows.

I'd appreciate any suggestion, or if someone points me where to get the default configurations.

Here are the settings:

 

/etc/systemd/system/resilio-sync.service. I changed user and group to myself to have files both synced and writeable, because otherwise I could not change files  after Resilio changed their ownership. (Adding myself to resilio group, or vice versa resilio to `culebron` group, did not help.)

[Service]
User=culebron
Group=culebron
PIDFile=/home/culebron/.config/resilio-sync/sync.pid
ExecStartPre=
ExecStart=
ExecStart=/usr/bin/rslsync --config /home/culebron/.config/resilio-sync/config.json

This settings file is picked up, because in those seconds when resilio runs, I see `sync.pid` appear in that folder.

 

~/.config/resilio-sync/user-config.json:

{
    "storage_path" : "/home/culebron/.config/resilio-sync/storage",
    "pid_file" : "/home/culebron/.config/resilio-sync/sync.pid",

    "webui" :
    {
        "listen" : "127.0.0.1:9999"
    }
}

 

Link to comment
Share on other sites

  • culebrón changed the title to Resilio-sync.service "deactivated successfully" after start [SOLVED]

Here's the full .service file to systemctl-enable it:

# cp this file to /etc/systedm/system/resilio-sync.service
# then:
# $ sudo systemctl daemon-reload
# $ sudo systemctl restart resilio-sync.service
# $ sudo systemctl enable resilio-sync.service
[Unit]
Description=Resilion Sync service
Documentation=http://help.getsync.com/
After=network.target network-online.target

[Service]
User=<your_user>
Group=<your_user>
Restart=on-failure
PIDFile=/home/<your_user>/.config/resilio-sync/sync.pid
ExecStartPre=
ExecStart=
ExecStart=/usr/bin/rslsync --config /home/<your_user>/.config/resilio-sync/config.json
Type=forking

[Install]
WantedBy=multi-user.target
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share