"Can't download file" - Which file? How do I fix it?


Recommended Posts


I just added a new machine to a folder I've been syncing to other machines without any issues.  The new machine has been syncing since yesterday and seems to be working just fine.  When I checked it this morning, the Status column says "Can't download file".  However, there's no information about what file it thinks it's 'having issues with.

There are no fancy permissions on the folder.  The History tab shows nothing under Error, Warning, or Info.  I checked the Source machine and it doesn't show any error message.  Just the destination shows the message.

The sync is still running, so whatever the error is, doesn't seem to be too important.  Is there somewhere I can look to figure out what file is causing the problem and how I go about resolving the issue?  I did a Rescan but it didn't seem to have any effect.


Link to comment
Share on other sites

  • 11 months later...

Is there any way to find out which file can't be downloaded?

I have the 2.7.3 1381 installed, I even reconnected/redownloaded these shares but still get an error and there is no file name shown. It's just an error.

In some cases I just got an error that can't sync multiple files but it was just a " ." , no filenames, nothing.

How could I identify this from logs or something?

There is always the one peer that's always connected and synced so it's/should not be a peer offline problem.

Link to comment
Share on other sites

  • 3 months later...

I'm syncing Pictures folder between Windows and Android. The "Can't download file" error is showing up on the Windows app after ~34% sync. 


The name of the files that's causing the error can be see by clicking the history icon, that looks like a clock. It is showing a whole bunch of files as "Failed to download - ERROR_FILE_CHANGED."

What does that mean? No other app is doing anything to those files while this sync is going on. 

I've already tried deleting the .sync folder from both my Windows machine and Android phone and starting the sync from scratch.

Sync 2.jpg

Link to comment
Share on other sites

  • 2 weeks later...

I figured out problem with my system. I had recently reinstalled Windows, and apparently that "corrupted" the owner field in all the files. The owner was replaced by a random alphanumeric value, which I'm guessing is internal tag/ref to my user in previous installation of Windows. Result of this was - large number of files became inaccessible to everyone, including me. (i.e. I couldn't double click to open those files either.) (Not sure why this access issue was occurring in some files, and not all files, even though all files had that "owner" issue.)

Anyway, I changed the ownership of all the files to my latest user after the Windows installation. The sync worked fine after that.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.