systemd: Error while opening config file, config file works when run from command line

Recommended Posts

Hello i have been trying to get resilio sync to work on a Linux machine, i have created a sync.conf which is working when run in configuration mode, however when i attempt to run using systemd service file i receive a error:

Can't parse config file "/home/user/resilioSync/sync.conf": "Error while opening config file /home/user/resilioSync/sync.conf"

Error while opening config file /home/user/resilioSync/sync.confError while opening config file /home/user/resilioSync/sync.conf

I have tried the /home/user/resilioSync directory with a owner and group of root, rslsync and user, however all return the same error. Is it possible the folder being within the user directory is causing issues?

here is my sync.conf , as stated i have had this exact config 100% working when run from command line.

	"device_name": "centOS",
	"listening_port": 8888,
	"storage_path": "/home/user/resilioSync/.sync",
	"pid_file": "/home/user/resilioSync/.sync/",
	"use_upnp": false,

	"shared_folders" :
		"secret": "mysecret",
		"dir": "/home/user/resilioSync/myfile",
		"use_relay_server" : true,
		"use_tracker": false,
		"search_lan": false,
		"use_sync_trash" : false,
		"overwrite_changes": false,
		"selective_sync": false

additional info:

Resilio Sync 2.7.3

CentOS Stream 9



Link to comment
Share on other sites

  • 2 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.