I can not execute SyncApp_arm on my NAS based on SL3516 CPU.

Recommended Posts

Recently I tried to run Sync App on my old NAS based on SL3516 CPU. But I got an error message like "-sh: ./SyncApp_arm-1.0.75: No such file or directory."

I made sure the execute are on correct location. So that error does not indicating executive file missing.

I guess this is some kind of compatibility issue, isn't it?

Link to post
Share on other sites

I got my raspberry pi working with some symlinking. That 'No such file or directory' is just terrible.

Sync is looking for all your libs in /lib, on my disto (raspbmc) they are all in /lib/arm-linux-gnueabihf/. Specifically ld-linux.so.3

symlink it to /lib with

sudo ln -s /lib/arm-linux-gnueabihf/ld-linux.so.3 /lib/ld-linux.so.3

assuming yours is in the same location as mine (use find if its not)

Then it finally worked:

pi@raspbmc:~$ ./SyncApp_arm --help

SyncApp 1.0.75

You may need to symlink some more (libc, librt, libdl, libm, libpthread). Thanks to Ivan for his help.



Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.