Windows Client Hangs With Encrypted Folder

Recommended Posts



I just start using btsync, because I search an alternative to Synology CloudStation, which has problems since last updates.


I install btsync to 2 computer with Ubuntu, a Android Smartphone, 2 Windows 7 PC and a Synology Diskstation 213+ and want to sync different folders.


I have an issue, when I add a folder, which is encrypted with encfs (originally created with BoxCryptor Classic in Windows) to a btsync Windows client. Btsync is not responding anymore after adding the encrypted folder. It is the same on 2 different notebooks with Windows 7 SP 1 64Bit and a VirtualBox-VM with Windows 7 32Bit.


In the sync.log are, after adding the folder, only messages

Incoming connection from ...

visible. No more work on other folders, which are added before.


On the linux-clients and the Android the problem does not occur with the same folder. On this clients the folder is mostly "out of sync", but sometimes files are transferred.


Because I added some big other folders to the clients, I assume, it is normal, that btsync needs some time to sync all files. But it is also possible, that the folder cannot be synced properly also on linux and android-clients. At least, these clients don't hang and worked on the other folders.


I already kill btsync on the windows-clients and delete the





and start btsync empty. It works then with other folders, but when I add the encrypted folder, the same problem occurs.


Has someone a solution for this? I need this encrypted folder on all clients. When btsync is not able to sync this folder, I have to search for another solution.


Thanks in advance.



Link to post
Share on other sites

I have some additional information to the encrypted folder, which causes the problems with windows sync-client:


The folder contains 344 files in 42 folders.

The file-names are encrypted too.


I changed singular files in the folder and see, that they are immediatly synched between the ubuntu-clients.


But the android-clients don't get the changed files. I create a new encrypted folder on a ubuntu-client, share it and sync with a empty folder in android. The encrypted files are copied to the android-folder very fast. But when I made changes, they are not synced. I see in the android-client, that 4 files have to be synced. But even manually sync do nothing.


I don't know, if this behavior in android has something to do with the hang of windows-clients. But it is another issue, which has to be solved. Otherwise I cannot use btsync for my needs.


I found a older post where issues with encrypted files are mentioned and that they are solved with version 1.4.99. I have the latest version 1.4.103 installed on ubuntu and version on android. Have the older android-version maybe still issues with encrypted files?

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.