Can't get latest rslsync to work


Recommended Posts

Hi, I have problems to get the latest rslsync working on Ubuntu Server 18. It worked for earlier version. But now it has stopped.

Status of resilio-sync is loaded and active. It runs as user rslsync. It listens to port 127.0.0.1:8888 so everything is ok.

My config file from /etc/resilio-sync/config.json is set like this:
 

{
    "storage_path" : "/var/lib/resilio-sync/",
    "pid_file" : "/var/run/resilio-sync/sync.pid",

    "webui" :
    {
        "force_https": true,
        "listen" : "127.0.0.1:8888"
    }
}

In order to access the Web-gui I set up a reverse proxy in plesk for Apache like this:

For http:

ErrorDocument 404 /404.html

ProxyPass / http://localhost:8888
ProxyPassReverse / http://localhost:8888

ErrorLog ${APACHE_LOG_DIR}/resilio_error.log
CustomLog ${APACHE_LOG_DIR}/resilio_access.log combined

For https:

ErrorDocument 404 /404.html

ProxyPass / https://localhost:8888
ProxyPassReverse / https://localhost:8888

ErrorLog ${APACHE_LOG_DIR}/resilio_error.log
CustomLog ${APACHE_LOG_DIR}/resilio_access.log combined

As I said these settings worked for earlier versions, but now with latest version from repository I get errors in the browser.

Brave gives the error connection refused

Firefox and Safari get a 500 error

Can someone give me a hint what goes wrong?

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.