Sync config file on Synology NAS

Recommended Posts

Where is the config file located on a Synology NAS running DSM 7?

According to THIS page it should be in /usr/local/resiliosync/var/ but unfortunately it does not have a resiliosync folder.

I did find a config file in /volume1/@appstore/resiliosync/app but it does not look like the one on THIS page.

The reason why I am asking is because I want to add the required lines to use my own trusted certificate.

Link to comment
Share on other sites

After many hours of trial&error I found the solution.

Created a Shared folder with the name ResilioSync.

Created a sub-folder with the name cert.

Copied cert.pem and privkey.pem (own trusted certificate) into sub-folder cert.

Used SSH to get into the Synology.

Went to /volume1/@appstore/resiliosync/var

In this folder you will find the configuration file sync.conf

sudo vi sync.conf

Enter password

Add the 2 ssl lines as below:

       "force_https": true,

        "ssl_certificate" : "/volume1/ResilioSync/cert/cert.pem",

        "ssl_private_key" : "/volume1/ResilioSync/cert/privkey.pem"


Save the file and restart (Stop/Start) Sync in the Package Center.

Now refresh the Web UI page and the certificate issue should be solved.

Edited by 747driver
Link to comment
Share on other sites

  • 3 months later...
  • 2 months later...
  • 3 months later...
  • 1 year later...

I have installed Resilio (Synology 7.2) and getting issues with the certificate and login / password request.  I never entered anything at the install so this boggled me.  Anyway, trying the above solution but confused about the step about :

Copied cert.pem and privkey.pem (own trusted certificate) into sub-folder cert.

Do I need to create a new certificate (frankly tried and failed.  if this is the route, I need steps!) or are these files located somewhere on my Synology to copy over?  I never had to deal with certificates before nor did I find any files for it. 

All help appreciated.   Thanks!  merci!  it's Fondue time!

Link to comment
Share on other sites

Well, not exactly. You can use your own internal domain name, or subdomain. But for HTTPS you must provide a domain name to be encoded into certificate so that browser wouldn't mark your resource unsecure.

PS: You can actually skip this and use plain HTTP over SSH, just make sure HTTP port is only available on localhost, then on your desktop do:

# add to ~/.ssh/config
Host your-server

This way you would be able to access your instance on on your desktop, but only when your SSH link to the server is active. And it's also secure the same way your SSH connection is secure.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.