PROPER setup for linux users


Recommended Posts

So after trying to fix this for days I finally managed to do this. After restarting my computer I noticed resilio sync would always restart in the rslsync user, even though I followed all the steps on the setup page.

The setup page for linux is about half of what you need to do but here is the rest...


After installing, do step 1


edit file /usr/lib/systemd/user/resilio-sync.service and change "" to "". Save this file


step 2

go to the config file at "~/.config/resilio-sync" and change listen x.x.x.x to "listen" : "".


step 3

save and restart linux


hopefully that will help you like it did with me



Link to comment
Share on other sites

  • 2 weeks later...

Using systemd is over-complicated.

I'd just write a simple script and use cron (of current user's crontab) to execute the script every 15 minutes.

The script would:

1. check a flag file to see if rslysnc for current user is enabled/disabled;

2. check if rslsync's storage is ready (e.g., the external usb drive for rslsync share is mounted);

3. check if rslsync for current user is running... if it's not, start it.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.