teh_g

Members
  • Content Count

    14
  • Joined

  • Last visited

About teh_g

  • Rank
    Member
  1. Hi all, btsync support was able to provide a resolution! In the config file for btsync, remove the "directory_root" or "dir_whitelist" parameter from the config. This parameter specifies the location where Sync can create folders. You could also modify it to include the specific folder you want to sync. If you are using the tuxpoldo repo, I have put it an issue to hopefully resolve this going forward: https://github.com/tuxpoldo/btsync-deb/issues/182
  2. Finally got my "Sync does not have permission to access this folder" issue resolved. I opened an issue in Github to implement a permanent fix: https://github.com/tuxpoldo/btsync-deb/issues/182
  3. I know my user has the proper permissions. Same user is running sync 2.0 as previously. I may downgrade for now, until we are sure of a fix.
  4. Thanks for updating! Sadly it didn't fix my issues with "permissions"
  5. The issue is still occurring after upgrading to 2.0.93.
  6. @tuxpoldo, is it possible to update the repo to the latest version? It allegedly will fix some issues I am having with the webui being silly about permissions.
  7. I cleaned up the folders as a part of my own troubleshooting. I will upgrade once >2.0.93 is available from the Debian repo. I am on 2.0.85 now.
  8. Missed this reply, sorry! I do have a ZenDesk ticket already. Here is how I have my setup: Source - Ubuntu Target - Debian I had my Debian machine as a backup using a read only key from the Ubuntu machine. After upgrading, I removed the old 1.4 style share and attempted to make a 2.0 share between the two. In Ubuntu, I had no issues and it happily created and indexed. When I try to use the share link from Ubuntu on Debian, Debian states that I do not have permission to write to the destination folder. As a test, I tried adding the exact same folder using the 2.0 system, this did not work. Adding a legacy folder (via Shift+Add Folder), allowed me to add that folder and have it indexed. I would use the 1.4 folder system until this is resolved, but if I try to add the 1.4 key from Ubuntu to Debian through the manual connection, it throws the permission error as well. I am not using the my devices option.I could give that a try. Edit: Actually, I can't try that, since I can't add the folder I want as my target folder.
  9. Hmm, I still have permission issues. I can't set the directory_root to the parent folder.
  10. I recently upgraded from 1.4 to 2.0 on my Debian server box. When attempting to recreate my 1.4 sync folder in 2.0, I am getting the error "Sync does not have permission to access this folder". I double checked, and Sync does have permission for this folder. The daemon is running as the same user it was in 1.4. If I make a 1.4 style sync folder, it appears to have no issue reading the data and no error is thrown. Unfortunately this is my "target" box for some one way syncing from a remote host, so I need to be able to add the key from my remote server. Even using the 1.4 style key, it throws permission errors.
  11. Having fun with this one, looks like it is an issue with Debian and the current build of BTSync. Potentially related to this issue: http://forum.bittorrent.com/topic/34404-synology-nas-isnt-working/ Adding a "1.4" folder by holding shift lets me add the folder as expected.
  12. I got the new version running on my Debian box, but the new version seems rather insistent that it doesn't have permission to write to many folders it does have permission to. The folder I am trying to re-add was the one I used with the previous version prior to upgrading. Edit: I did an uninstall and cleanup of btsync for fun, and the issue is still occurring. I double checked that the user running btsync is the owner and a member of the group that owns the folders and files.