NO DEVICES


bsemps

Recommended Posts

That should "just work."

Maybe your computers are having a hard time talking to the BT tracker on the Internet?

Try adding the IP address of each computer to the share definition:

  1. Preferences -> make note of the port number on each computer
  2. Shared Folders -> double click the share
  3. Hosts -> Add -> put in every other computer's IP address and port number
  4. Restart BTSync for good measure (might want to check the port number again in step #1 after doing this to make sure it didn't change?)

Any difference?

If not, probably need to turn on the debug log and send it in for analysis.

Also, even if this does work, there doesn't seem to be an option in the GUI version to not randomize the port on each start ... not sure if it does that by default or not ... I haven't checked.

Link to post
Share on other sites

Sure, please follow this steps, so we could localize your problem

Most likely you have upd packets blocket in some of your networks, so Sync couldn't contact another peer. Could you please check that you FW doesn't block UPD traffic?

Link to post
Share on other sites

And by UPD traffic, kos13 actually means UDP traffic. :-P

You can also use the advanced options to switch BTSync to use TCP instead of UDP on your LAN and see if that makes any difference. I would be very surprised ... which brings me to another thought...

Are you using a firewall software on your computers? Like ZoneAlarm or Kaspersky Internet Security, etc.? Disable those and see if it works ... BTSync makes firewall exceptions into the default basic Windows Firewall, but it probably doesn't handle the others, and you may not have noticed those programs ask you to open the ports (or have those alerts turned off)...

Just a thought.

Link to post
Share on other sites

Tried turning off Firewall but no good.

Where is the TCP option? Could not see in Preferences/Advanced except a true/false choice on something with TCP. But see no UDP at all.

Kos13 ...where is the SynceApp icon? I see none for the debugging.

Link to post
Share on other sites

Want me to look things over for you? Run the following commands from a command prompt on both computers, then copy and paste the results here.

  • ipconfig /all
  • route print
  • ping google.com
  • ping 8.8.4.4

If you're familiar with the output of ipconfig, also try pinging the other computer from each computer. If you aren't, I'll give you the commands to use once I see the output from the ones above.

Link to post
Share on other sites

Make sure that your folders are using the same secret. I had the same problem, scoured the net for a solution, and finally found that my secret had been copied twice into one of the folders as I set them up. I'd assume it was me that made that mistake, but since it happened two times, once for my Ubuntu Server setup (where I noticed it and fixed it) and once for my mac, I have a suspicion that some copy mechanism is not working properly. Or then I'm just more clumsy than usual today. :)

Anyways, after fixing that little mishap everything is working perfectly! Many thanks for this wonderful tool!

Link to post
Share on other sites

Where is the TCP option? Could not see in Preferences/Advanced except a true/false choice on something with TCP. But see no UDP at all.

That IS the TCP option - the "lan_use_tcp" option. If set to "true", BitTorrent Sync will use TCP instead of UDP for local connections across your lan (this won't disabled UDP for external connections though - there isn't currently a setting to allow you to do this)

...where is the SynceApp icon? I see none for the debugging.

Assuming you're running on Windows, the sync icon is a circular blue icon with two semi-circular white arrows within, and should be present in the system tray near the clock to the bottom right of your screen. If you right click this icon there's an option to "Enable debug logging"

Link to post
Share on other sites

Windows tools for doing a UDP traceroute are in short supply, even WinMTR fails in that respect (unlike the linux version).

This tool seems to do the job: http://r1ch.net/stuff/ftrace/

Unlike mtr it doesn't overlap the probing of the hops so it's a bit slow, but it gets the job done.

WARNING: UDP mode needs Administrator privs to see the replies; if it doesn't have them it never sees any replies.

Link to post
Share on other sites

Archived

This topic is now archived and is closed to further replies.