Sign in to follow this  

Getting BTSync work on my PPC QorIQ device

Recommended Posts



I have a WiFi router that runs OpenWRT and does not have a MIPS CPU but rather a Freescale PPC QorIQ CPU.


So I tried the PPC QorIQ version of BTSync but got:

./btsync: No such file or directory

I figured it might be because OpenWRT uses uClibc instead of glibc.


I can build my own OpenWRT with eglibc (notice the "e"!). But it takes time and I want to ask for advice before trying and wasting time.


My question is: Is uClibc really the problem? If yes, does BTSync work with eglibc or is glibc really needed? Other remarks?



Share this post

Link to post
Share on other sites

I can assure you, I am not that dumb. It is extracted and i run it corretly. On my Ubuntu machine I run the correspoinding exectable (there of course the x86) the exact same way and it works.


The not found error is a dependency error on OpenWRT.

Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this