Where are my folders ? : Android client


Recommended Posts

OK - I've been using RSL 6-7 years - worked a treat for me... loved it so much I bought a pro license in 2018 and use it instead of Dropbox...

Works nearly everywhere, nearly flawlessly...  I mostly run Mac or Linux (mostly Linux)...  but never had any major issues running it on my previous job's Windows 10 laptop either... Had a few issues with an iPad (3rd gen - yeah! ~4-5 years ago) ...  But NO issues running it on my iPad pro 12.9" (2nd gen)...  Also running it happily on a few headless ARM Linux machines... works a treat... no complaints (other than a few gripes with how it doesn't play well with SystemD on Pi Zero's - the armhf binary doesn't seem to like those - I have to run the binary manually anyway)...

But - decided to automate syncing music to my android phone, "stock" Galaxy S9+ (not rooted or anything) running Android 10...  Ran into a heap of issues...  Basically the app would just crash - no feedback.. fire it up... crash... sometimes I get to kill it (or wait)... So - I removed it...  re-installed - same issue, it would just crash...    If I can't fix this, I'll have to do it manually - which I can probably figure out with a combo of TermUX and rsync - but - I SHOULDN'T have to kludge this!

Troubleshooting for crashing (after my first uninstall/re-install did bupkis) 

1. "Clear cache"

2. "Clear date"

3. uninstall.

Browsed to my SD-Card from my Linux machine (i.e. using MTP over USB) deleted EVERYTHING I could find that looked like RSL stuff (bear in mind - this SD-Card has been cloned, and cloned again, and started life in a Galaxy Note 3, then a Nokia 4.2, before insertion into this Galaxy S9+)...

Powered off.

Re-installed App...

Used QR-scan to grab one of my smaller sync targets ( less than 5 GB)...  It took forever to sync, but it finished (and crashed a few times!)... Now I tried to rename it from "old-name (2)" to just "old-name" (that's a place holder for the real name) - but it wouldn't let me - like it already "knew" it had once had a sync folder by that name... So - I decided to rename it to "...BUCKET" - and that worked... But now I cannot rename it back to "old-name"!

And worse than that - I have NO IDEA where on my SD-Card this sync target is located.  I can't find it browsing over MTP via USB from my Linux box... Maybe I'll have to power off and insert the SD-Card into a reader on one of my Linux machines?  See I don't mind, or care, that the iOS / iPadOS version abstracts direct filesystem access, as I don't need this on my iPad, BUT I WANT it on my Android phone, 'cause it's my music player, and I need to be able to point my (FLAC) music player "Music Folder Player Full" at the location of my sync'd music folder - BUT WHERE IS IT?

I also, really don't want to wipe/format this SD-Card (256 GB)...  that's extreme...

 

 

Link to comment
Share on other sites

Update - Sync is quite possibly the flakiest Android app I've EVER come across...  it just completely crashes... every time!

Looks like I'm now in the market for some other solution than with my Resilio Sync pro license...

Note : after several wipes, deleted the folders Sync created on my internal storage, forced it to use SD-Card, added a new sync target from scratch (scanned QR code) - and I see it on my SD-Card when I connect from my PC (running Linux) - and in an Android file browser I can navigate to it on my SD-Card, so "Dude, I found my files" - but - there's hardly any there 'cause the dang app just keeps constantly crashing...  My Galaxy S9+ is nothing special, not rooted, stock, latest updates from Samdung (sic).  Why so flaky?

Link to comment
Share on other sites

  • Helen changed the title to Where are my folders ? : Android client

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share