beo6

How To Force Btsync To Create Directories?

Recommended Posts

Hello,

 

i got a bit of an issue and i currently don't know how to solve it the best.

 

 

When i Synced a directory structure it works very well. However when i delete a subdirectory

btsync only prints a lot of errors like:

TorrentFile: Failed to create empty suffix for file "directory/dir2/dir3/file" - 3SyncFilesController: failed to load torrent for file "directory/dir2/dir3/file"

The only way to have it sync again completely is to create every directory and subdirectory manually.

After i created them it syncs again.

 

 

Do i really need to create all directories myself in my application?

 

 

Thanks in advance for any help.

 

Share this post


Link to post
Share on other sites

@beo6

 

Not actually. If you remove the directory - it should get removed on all other peers automatically. Could you please share a bit more information - which peers are involved (OS, device, RO/RW)? Also, which amount of time did you give btsync to pick up the changes?

Share this post


Link to post
Share on other sites

Hello and sorry. Shoulf have really provided more informations but it was late for me. :)

 

There are multiple peers involved. But basicly it is 1 master-server which has the read-write access and all other peers have read-only.

The master-server is Linux, most other peers are Windows or Linux.

 

Which is possibly important is that i use the selective sync feature for all windows peers so it is not necessary to sync all folders from the master-server.

 

I waitet quite some time (not exactly sure how long but i would say it should have been able to create the folders)

 

 

The whole application purpose is an updater tool so all other peers should never be able to make changes on the sync folder. But it is of course possible that they delete some folder and after that BTSync seems not to recreate them at the next sync.

 

For the moment i create all folders and subfolders from my application with the help of the get_files method and it works very good. But i wonder if btsync shouldnt create them.

Share this post


Link to post
Share on other sites

beo6, 

 

You delete the subfolders on the read-only Windows and then they are not synced again from Linux, right? If I understood you right, then it's normal behavior.

To have them synced back, open the folder settings in BitTorrent Sync on the R-O Windows  and enable "Restore modified files to original version". All the files and folder that were edited on the R-O peer, will be downloaded again to r-o peer. 

 

And could you please tell us how you use selective sync on Windows?? What it this feature that you use? 

Share this post


Link to post
Share on other sites

I have a similar issue in both 1.3 and 1.4.103, except I am not deleting the subfolders, it is simply not creating new ones when needed.

 

I have a linux server with the r/w key, and a windows server with the r/o key. I use it to xfer files automatically to be reorganized on the Windows side, so it's never "in sync" - xferred files are moved out and processed, and the empty subfolders are left behind (which is fine for me.)  On the linux side, the folders remain populated for x days before deleting themselves.

 

Initially it was fine, but now I get the reported log errors when it needs to create new sub-folders that have not yet been created nor deleted in the Windows box. And in 1.4 the "Restore modified files" option is gone. If I select "Overwrite any changed files", it begins to sync the entire folder again, including files it has already synced and processed(moved out.)

 

EDIT: I realized now what I did wrong. I moved my folder hierarchy into the r/o folder so that it would index/sync without duplicating downloads, then I moved it out. So sync must think they were deleted and will no longer create them again.

Is there a way to edit sync's "memory" to let it create the subfolders again if needed? Re-indexing is extremely difficult in my installation.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.