Recommended Posts

I'm using QNAP TS451 with 4.2 firmware. I plan to sync photos across my iPhone and wife's iPhone, or at least back them up on the server. Every other app has sucked so far, so this looked promising. 

First time I loaded the qpkg just by searching with the built in QNAP app manager (ver 2.3.6) and though the btsync screen loaded beautifully and was user friendly, if I tried to link my phone and set a destination folder, it errors saying "sync doesn't have permissions to this folder" no matter where I put it. Even pre creating the folder in QNAP. 

I tried to change permissions to give admin (and even a group called btsync) access to the folder and still no joy. So I saw a tutorial recommending installation of btsync by manual installation in the QNAP app screen, so I uninstalled and reinstalled manually and now the btsync screen won't load at all. So I uninstalled and reinstalled the other way and still won't load. 

Any ideas???

Link to post
Share on other sites

1. Permissions. It's plain simple: need to check under what user sync runs (ps aux | grep sync in ssh), and then give this user rw access. 

2. UI won't load - do you mean that it errors out with "This site can’t be reached" or "NO_CONNECTION", or that it's blank? 

If the former, make sure that Sync process runs actually (again, with "ps aux | grep sync" command). that IP:port in address bar is correct. 

if the latter, try reinstalling again with deleting everything from /share/HDA_DATA/.qpkg/BitTorrentSync/ before installing. 

Link to post
Share on other sites

Thank you for the tip. The BitTorrent screen is loading now without changing anything... maybe it was still loading when I tried.

While your tip sounds logical enough, BitTorrent is running as admin, and admin has access to all shared folders. I even had the permissions rebuilt from the sharefolder management screen, and BitTorrent still says it doesn't have access.

Hell, the folders are OWNED by admin.

What am I missing here?

Edited by MicDunDee
Link to post
Share on other sites


It's pretty plain straightforward: the user shall have access to the folder itself and of course to all parent folders.

Can you please show the output of two commands: 

ps | grep sync (to see the user) 

ls -al /path/to/the_parent_folder ( where your wanted sync share's path is /path/to/the_parent_folder/sync_share) to see permissions


Link to post
Share on other sites

Hope this is enlightening to you, it seems fine to me so far... could it be a permission of a folder above it? Seems like everything is owned by admin, with read/write/execute permission for owner and group (just like folders below).

ps | grep sync

 8574 admin       912 S N /usr/bin/rsyncd --daemon --sever-mode=1 --qnap-bwlimit 
 9914 admin      1220 S   /usr/bin/qHAsyncman 
 9942 admin      1376 S   /usr/bin/qsyncman 
13981 admin      9620 S   /share/CACHEDEV1_DATA/.qpkg/BitTorrentSync/btsync --config /share/CACHEDEV1_DATA/.
30655 admin       536 S   grep sync

ls -al /share...

# the folder itself
drwxrwx---    7 admin    administ      4096 May  7 21:09 Photos Every Day/

# inside the folder
drwxrwx---    7 admin    administ      4096 May  7 21:09 ./
drwxrwxrwx   14 admin    administ      4096 May  7 21:24 ../
drwxrwx---    3 admin    administ      4096 Apr 30 21:38 .sync/
drwxrwx---    2 admin    administ      4096 Apr 30 22:00 Dora iPhone/
drwxrwx---    2 admin    administ      4096 Apr 30 22:00 Mike iPhone/


Link to post
Share on other sites

I'm having the exact same permissions issue.  Sync is running under user 'admin' for me as well, and this user has read write access to the share I want to sync, but I get the 'Sync does not have permission to access this folder' error.

I'd rather sync ran under a different user really which was dedicated to sync so that I can control what files it has access to.

Link to post
Share on other sites


Yes, the parents folders also count. What is the full path to Photos Every Day/? If everything seems OK, is it possible for you to take a short video or at least screenshot of the error and take the logs from this NAS (/share/CACHEDEV1_DATA/.qpkg/BitTorrentSync/storage). PM everything to me. 


We will consider changing the user. 

As for permissions - same tips: check parent folders as well, and if still no luck, please send the logs and screenshot to me. Thanks. 

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.