Syncing Large Music Folder To Sd Card On Android

Recommended Posts

The problem


I manually rsynced a large mp3 directory to an ext4-formatted micro SD card on my Linux computer, proceeded to mount the card on my Cyanogenmod 11-equipped Galaxy S5 with correct permissions, and added the directory to the Sync app with a read-only key.  When syncing it manually on the phone, it will start "Receiving" but never finish, with a minimal ~7B/s transfer rate.



  • The music folder in question contains 17.07GB and 2872 files.  The files are mostly mp3s ranging from 1 to 10 MB in size.
  • The folder syncs successfully between two Linux computers running Ubuntu 14.10, Ubuntu 14.04, and Sync 1.4.103 in the same local (Wifi) network.
  • There's nothing encrypted in the directory.
  • It's music, so filenames vary wildly.  There are no characters that are illegal to FAT32 (even though the SD card is now formatted as ext4).
  • The phone is running Cyanogenmod 11 (based on KitKat 4.4.4), but the Cyanogenmod developers have reverted the SD card permission restrictions.  I did have to manually change the permissions of the files/directories on the SD card, though (chown -R media_rw:media_rw /media_rw/sdcard1, chmod -R ug+rw /media_rw/sdcard1).

Things I tried


This problem originally appeared on the Galaxy S5's stock KitKat 4.4.2 ROM.  Rooting it and editing /system/etc/permissions/platform.xml solved the (then FAT32) SD card permissions issue, but Sync wasn't able to finish syncing the mp3 folder either.


Figuring this might be due to some other arbitrary restriction imposed by Samsung or my carrier, I flashed the latest Cyanogenmod 11 nightly available for my phone, and tried again: no luck.


I resorted to formatting the card with ext4, thinking the problem might be related to a FAT32 limitation.  One again, no luck.


Finally, I tried enabling the tracker server and relay server options for this folder on the Linux boxes.  No good, either.


What next?


Any ideas as to what I might try next?



Share this post

Link to post
Share on other sites

Was there a solution to this? I have the same issue, but syncing on a Nexus 7 2013 WiFi running 4.4.4, and an external USB HDD that stores my music.


I have a similarly large and diverse music library as you (20+GB). Sync computers are 3 different Windows computers (one local), running 1.4.111.

Share this post

Link to post
Share on other sites

The support staff has informed me this is a known issue, and there is no fix for the currently released versions.  This is what they told me, verbatim:


"According to your description, you've encountered a known bug with synchronization for android. We'll fix it in future updates. Now as workaround you can move your files outside your shared folder then put it back.

Also we couldn't reproduce it for the upcoming 2.0 version. So if you want to test it, you can go this link:"


I have yet to try any of the proposed solutions.  Maybe you can do so and report back? ;)

Share this post

Link to post
Share on other sites

Hm. It looks like I would have to sideload the apk for 2.0 beta? I'm not too familiar with the procedure on this, and the readme links are dead. I would like to give it a try though.

Share this post

Link to post
Share on other sites

ninja6o4, you can update to 2.0 version via Google Play. But if you don't use it, you can download 2.0 version here.

Thanks I didn't realize they had pushed it to Play store.

I updated my Sync and it appears to be sync'ing normally (getting ~20-30mbps over my wifi g network.)

The rest of my machines are still running 1.4.111, only the tablet is on 2.0, and so far, so good.

Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.