Computers Not Completing Sync, Stuck In Same Upload/download Amount?


Recommended Posts

Is it possible to be stuck in some sort of endless sync loop when several machines all connect? I have 4 machines connecting (iMac, Macbook Pro, Computer 2 (Windows) and my server (Linux box).


My iMac states 1.5Gb UP to my server, and 5.8Mb DOWN from computer 2, and synced with my Macbook Pro

My Macbook pro states 1.1Gb UP to my server, and 5.8Mb DOWN computer 2, and synced with my iMac

Computer 2 states 1.5Gb UP to my server, 5.8Mb UP to my iMac, and 5.8Mb UP to Macbooc Pro


Its been stuck like this for ages, they should have all synced by now. All on the same LAN. My Macbook and Macbook Pro all have the sync icon spinning, but no change in these values. 


iMac and Computer 2 is set to connect to my office server as a preferred host

Link to comment
Share on other sites

Firstly, be aware that Sync can't sync files whilst they're open/locked/in use by other applications. Sync will still indicate an amount of data to upload/download, but no transfer will take place until the files (or their associated applications) are closed.


If you're confident that that is not an issue in this case, then the following steps may well resolve your issue:

  1. Close Sync on all your devices
  2. Locate and delete any .!Sync, .SyncTemp, .SyncPart, and .SyncOLD files in the folders you're syncing
  3. Restart Sync
Link to comment
Share on other sites

OK thanks.


It seems maybe I'm wrong with an endless loop theory, instead maybe just a status issue in the app. For example, I know my machine has synced with my server, but my machine still says UP 1.9Gb. This has not changed. But looking at the files, they are in sync. 


So maybe its just the app not showing correct status. 


I just looked on all my computers (Macs and Windows) and they ALL state UP 1.9Gb to my office server. The office server is running Centos 6.3. So therefore do you think the issue is with Linux not reporting its synced with the other machines? 



Link to comment
Share on other sites

I'm having this problem for a long time; sometimes I can get to fix it but it comes back after some time. Now I can't find any .!Sync, .SyncTemp, .SyncPart, or .SyncOLD files. I removed sync folders on both sides and even deleted synced folders. Added sync folders again and... after indexing and transfers, the amount of unsynced data changed but it still stucks there, with some amount of that left to upload/download.


I'm using 1.2.73 on every PC (win7 and win 8.1 64 bits)


The most problematic folders are the ones that host my work files which change very frequently.

Link to comment
Share on other sites

It's the same problem I'm having.

I also tried deleting some files (which propagates correctly to the other PC) and adding them again: BTSync synced only one file, leaving the other 2 in a sort of limbo. Both ends know and show there is still this data to be transferred, but the transfer does not happen.

Link to comment
Share on other sites

I have a multi GB collection of images that I sync between two computers.  The images are synced correctly, but there are always a few MB of data remaining that do not transfer (correctly reported on both machines).  I have discovered that the remaining files are hidden ".picasa.ini" files located in each directory.  The total number of these and the their size seem to match what Sync is reporting as pending.  Not sure if it will help you, but it seemed to be a similar problem.

Link to comment
Share on other sites

  • 1 month later...

I have a similar problem which I haven't ever had until the most recent update. I have around ten files to sync, and they'll begin to sync, then stop syncing, but show download speeds of around 0-1 kbps. I've tried everything I could find on this forum, from disabling relay server, to deleting the .sync file and restarting the program, but nothing has worked yet. The few files that did download to nearly their entire size are still sitting as .sync files. I let the program run overnight for 2 nights now, and they haven't downloaded! I hope this is resolved, BTSync is one of my favorite programs!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.