ajp_anton

Asking for new identity

Recommended Posts

I just restarted the sync service, and when it started and I refreshed the webpage, it asks for a new identity. This is now the third time and the second computer on which it happens, previously it has happened when I restarted Windows.

Can it be resolved in another way than to create the identity, re-link the device, and re-sync TB's of data?

Share this post


Link to post
Share on other sites

@ajp_anton This will happen if Sync's storage is not available, or setting there are either removed or damaged, so that Sync was not able to read them and load your identity. Another possible reason is that Sync was not quit correctly and thus was not able to save the settings. Storage is C:\Users\user\AppData\Roaming\Resilio Sync Rervice but please not that the storage folder path could be different.

I advice you to send logs to support team for the further issue investigation.

Share this post


Link to post
Share on other sites
5 hours ago, Gane O'dwyer said:

@ajp_anton This will happen if Sync's storage is not available, or setting there are either removed or damaged, so that Sync was not able to read them and load your identity. Another possible reason is that Sync was not quit correctly and thus was not able to save the settings. Storage is C:\Users\user\AppData\Roaming\Resilio Sync Rervice but please not that the storage folder path could be different.

I advice you to send logs to support team for the further issue investigation.

What, so you're telling me that if I shut down my computer or restart the sync service, the service will randomly quit improperly and lose all its data? What kind of design is that? How do I even ensure that it quits properly?

There was nothing wrong with the storage folder. While it was asking me for a new identity, I went there to take a look. There was for example a "1kB" (might be smaller) sync.dat, and a 33kB sync.dat.old. I'm guessing the *.old files contained the old identity and data. I planned to shut down the service without creating a new identity, rename the *.old files, and start the service again. Unfortunately, shutting down the service overwrote the *.old files, didn't think of backing it up first. But obviously RSync did have access to that folder.

Share this post


Link to post
Share on other sites

I also just quit Resilio and when I reopened it it had lost my identity completely, acting as though the program had never been opened on my device. Please advise how to fix this problem, as it is a big one and could cause me to cancel my account if I can't get it resolved ASAP.

Share this post


Link to post
Share on other sites

@HelenI have a same problems, last year, many versions of Sync

my NAS-es: Synology 1513+, 1815+, 1817+, QNap TS897Pro, Windows 2012R2 - all of them has a same problem:

Randomly lost of identity and all folders after NAS reboot or Sync service reboot. I need to add all shares again and again

Today I stop and start Sync service at DS 1513 - and lost identity and all 15TB shares. Manual add shares, wait rebuild of 15TB shares. Until next NAS update or reboot. [censored]!

License: Sync Pro presonal

Share this post


Link to post
Share on other sites

@Helenwhen I check log file on any NAS or Windows server, I see graceful shutdown. And after startup log records about broken sync.dat. Today, for example:

shutdown:

[20171113 11:28:10.049] GS: shutdown
[20171113 11:28:13.560] unregister diskio completion queue with id 1
[20171113 11:28:13.561] Torrent session shutdown: done waiting
[20171113 11:28:13.561] D! 10SyncTcpReq[0x00007fcbf8031ad0][None-TUNNELL] [0000]: destroing F8031AD0 cbcnt:4, error: 0, wb: 0 - incoming merge
[20171113 11:28:13.561] D! 10SyncTcpReq[0x00007fcbdc0a9b00][None-TUNNELL] [94DC]: destroing DC0A9B00 cbcnt:3, error: 0, wb: 0 - outgoing merge
[20171113 11:28:13.561] Stopping network threads
[20171113 11:28:13.587] Stopping UDP threads for 0.0.0.0:25506
[20171113 11:28:13.649] Stopping UDP threads for [::]:25506
[20171113 11:28:13.719] Shutdown. Saving config sync.dat
[20171113 11:28:13.719] diskio thread stop, drive_id = 31
[20171113 11:28:13.719] diskio destroy, drive_id = 31
[20171113 11:28:13.720] diskio thread stop, drive_id = 18446744073709551614
[20171113 11:28:13.720] diskio destroy, drive_id = 18446744073709551614
[20171113 11:28:13.720] diskio_controller destroyed

startup:

[11:28:21.425] Debug log mask has been set to FFFFFFFF
[11:28:21.425] Features mask has been set to 0
[20171113 11:28:21.427] ZIP: Can't locate [version] in zip, error -100.
[20171113 11:28:21.428] I! Configuration from file "/usr/local/resiliosync/var/sync.conf" has been applied
[20171113 11:28:21.431] Directory root is ""
[20171113 11:28:21.432] test sha1: AE5BD8EFEA5322C4D9986D06680A781392F9A642
[20171113 11:28:21.432] test sha2: 630DCD2966C4336691125448BBB25B4FF412A49C732DB2C8ABC1B8581BD710DD
[20171113 11:28:21.432] test aes: 0A940BB5416EF045F1C39458C653EA5A07FEEF74E1D5036E900EEE118E949293
[20171113 11:28:21.432] diskio_controller created
[20171113 11:28:23.078] register diskio completion queue with id 1
[20171113 11:28:23.078] PLC[0x00007f3079d4b9e0] binding on 0.0.0.0:25506
[20171113 11:28:23.079] D! 20PeerListenConnection::listen[0x00007f3079d4b9e0][8] bound listening socket 8 to IP 0.0.0.0:25506
[20171113 11:28:23.079] PLC[0x00007f3079d4ba20] binding on [::]:25506
[20171113 11:28:23.079] D! 20PeerListenConnection::listen[0x00007f3079d4ba20][9] bound listening socket 9 to IP [::]:25506
[20171113 11:28:23.079] UDP: bound listening socket 10 to IP 0.0.0.0:25506
[20171113 11:28:23.079] UDP: bound listening socket 11 to IP [::]:25506
[20171113 11:28:23.079] D! 20HttpListenConnection::listen[0x00007f3079d4bcb0][12] bound listening socket 12 to IP 0.0.0.0:28888
[20171113 11:28:23.182] register diskio completion queue with id 2
[20171113 11:28:23.195] Create diskio thread for drive with id 5297793138, path:
[20171113 11:28:23.196] Create diskio thread for drive with id 5010121870, path:
[20171113 11:28:23.196] diskio thread start, drive_id = 5297793138, priority = normal
[20171113 11:28:23.196] Create diskio thread for drive with id 4356430267, path:
[20171113 11:28:23.196] Create diskio thread for drive with id 5124781051, path:
[20171113 11:28:23.196] diskio thread start, drive_id = 4356430267, priority = normal
[20171113 11:28:23.196] diskio thread start, drive_id = 5124781051, priority = normal
[20171113 11:28:23.197] diskio thread start, drive_id = 5010121870, priority = normal
[20171113 11:28:23.197] IPv6 is installed
[20171113 11:28:23.198] VerifyFileWithHash failed on file /usr/local/resiliosync/var/sync.dat with status 4.
[20171113 11:28:23.199] VerifyFileWithHash failed on file /usr/local/resiliosync/var/sync.dat with status 2.
[20171113 11:28:23.200] VerifyFileWithHash failed on file /usr/local/resiliosync/var/sync.dat with status 4.
[20171113 11:28:23.200] Unsupported or empty sync.dat file

[20171113 11:28:23.200] My PeerID: 10D3D46549F808713529FA7EDA049F9A17C97BAD
[20171113 11:28:23.201] LC: LoadLicenses: there is no pro license
[20171113 11:28:23.233] loaded history: 1000 events
[20171113 11:28:23.241] Joining to the multicast group 239.192.0.0:3838 on interface 10.1.2.66 (eth0)

......

Share this post


Link to post
Share on other sites
3 minutes ago, Helen said:

@AL40k, please, send all debug logs to support. Thank you.

Logs posted above. All cases are identical. Shutdown, sync.dat is saving. Startup, sync.dat "VerifyFileWithHash failed". Dozens of times the same thing :(

Share this post


Link to post
Share on other sites

This has now happened to my Sync "server" which stores the 30TB of folders I sync to different devices.

As you suggested to AL40k, I posted my logs as well as a descrption of the issue to your "Submit a Regquest" webpage.

However, after attaching the files, and pressing "submit" at the bottom of the page, nothing happens.  I still have the page open and have clicked "submit" several more times. ... ..

 

update: I seems I had too many log files attached so I reduced the number and only uploaded/attached what it would allow.

Share this post


Link to post
Share on other sites

yes, the form allows only 20Mb of attachments. If you have more than that, contact support without logs and ask them for link to upload all the logs. 

Share this post


Link to post
Share on other sites

Hello!
I have exactly the same problem. And also for the third time.
A year ago on Windows, six months ago - on the Sinology DS116.
Two days ago this happened on Debian 9.2 (Sync 2.5.9).
There was a normal reboot of the virtual machine. The shutdown was correct.
After the start, he requests a new identity:

[20171118 07:10:08.838] GS: shutdown
[20171118 07:10:08.885] unregister diskio completion queue with id 1
[20171118 07:10:08.885] Torrent session shutdown: done waiting
[20171118 07:10:08.885] Stopping network threads
[20171118 07:10:08.886] Stopping UDP threads for 0.0.0.0:43119
[20171118 07:10:08.968] Stopping UDP threads for [::]:43119
[20171118 07:10:08.996] Shutdown. Saving config sync.dat
[20171118 07:10:08.996] diskio thread stop, drive_id = 5354007485
[20171118 07:10:08.996] diskio destroy, drive_id = 5354007485
[20171118 07:10:08.996] diskio thread stop, drive_id = 5165816562
[20171118 07:10:08.996] diskio destroy, drive_id = 5165816562
[20171118 07:10:08.996] diskio thread stop, drive_id = 5105521278
[20171118 07:10:08.996] diskio destroy, drive_id = 5105521278
[20171118 07:10:08.996] diskio thread stop, drive_id = 5022623812
[20171118 07:10:08.996] diskio destroy, drive_id = 5022623812
[20171118 07:10:08.996] diskio thread stop, drive_id = 4852457946
[20171118 07:10:08.996] diskio destroy, drive_id = 4852457946
[20171118 07:10:08.996] diskio thread stop, drive_id = 4834938076
[20171118 07:10:08.997] diskio destroy, drive_id = 4834938076
[20171118 07:10:08.997] diskio thread stop, drive_id = 4638700508
[20171118 07:10:08.997] diskio destroy, drive_id = 4638700508
[20171118 07:10:08.997] diskio thread stop, drive_id = 4383625789
[20171118 07:10:08.997] diskio destroy, drive_id = 4383625789
[20171118 07:10:08.997] diskio thread stop, drive_id = 41
[20171118 07:10:08.997] diskio destroy, drive_id = 41
[20171118 07:10:08.997] diskio thread stop, drive_id = 18446744073709551614
[20171118 07:10:08.997] diskio destroy, drive_id = 18446744073709551614
[20171118 07:10:08.997] diskio_controller destroyed
[07:20:25.117] Debug log mask has been set to FFFFFFFF
[07:20:25.117] Features mask has been set to 0
[20171118 07:20:25.158] ZIP: Can't locate [version] in zip, error -100.
[20171118 07:20:25.159] I! Configuration from file "/etc/resilio-sync/config.json" has been applied
[20171118 07:20:25.160] test sha1: AE5BD8EFEA5322C4D9986D06680A781392F9A642
[20171118 07:20:25.160] test sha2: 630DCD2966C4336691125448BBB25B4FF412A49C732DB2C8ABC1B8581BD710DD
[20171118 07:20:25.227] test aes: 0A940BB5416EF045F1C39458C653EA5A07FEEF74E1D5036E900EEE118E949293
[20171118 07:20:25.281] diskio_controller created
[20171118 07:20:25.291] register diskio completion queue with id 1
[20171118 07:20:25.291] PLC[0x0000560ebe21c6e0] binding on 0.0.0.0:43119
[20171118 07:20:25.291] D! 20PeerListenConnection::listen[0x0000560ebe21c6e0][10] bound listening socket 10 to IP 0.0.0.0:43119
[20171118 07:20:25.291] PLC[0x0000560ebe21c170] binding on [::]:43119
[20171118 07:20:25.291] D! 20PeerListenConnection::listen[0x0000560ebe21c170][11] bound listening socket 11 to IP [::]:43119
[20171118 07:20:25.291] UDP: bound listening socket 12 to IP 0.0.0.0:43119
[20171118 07:20:25.291] UDP: bound listening socket 13 to IP [::]:43119
[20171118 07:20:25.291] D! 20HttpListenConnection::listen[0x0000560ebe224240][14] bound listening socket 14 to IP 0.0.0.0:8888
[20171118 07:20:25.304] register diskio completion queue with id 2
[20171118 07:20:25.308] Create diskio thread for drive with id 5269615452, path: 
[20171118 07:20:25.308] Create diskio thread for drive with id 4351108565, path: 
[20171118 07:20:25.308] Create diskio thread for drive with id 4316136436, path: 
[20171118 07:20:25.308] diskio thread start, drive_id = 5269615452, priority = normal
[20171118 07:20:25.308] diskio thread start, drive_id = 4316136436, priority = normal
[20171118 07:20:25.309] diskio thread start, drive_id = 4351108565, priority = normal
[20171118 07:20:25.309] Create diskio thread for drive with id 4358415364, path: 
[20171118 07:20:25.309] Create diskio thread for drive with id 4651105100, path: 
[20171118 07:20:25.309] Create diskio thread for drive with id 4321785616, path: 
[20171118 07:20:25.309] diskio thread start, drive_id = 4358415364, priority = normal
[20171118 07:20:25.309] Create diskio thread for drive with id 4430427224, path: 
[20171118 07:20:25.309] diskio thread start, drive_id = 4651105100, priority = normal
[20171118 07:20:25.309] Create diskio thread for drive with id 4739376259, path: 
[20171118 07:20:25.309] diskio thread start, drive_id = 4321785616, priority = normal
[20171118 07:20:25.309] diskio thread start, drive_id = 4430427224, priority = normal
[20171118 07:20:25.309] diskio thread start, drive_id = 4739376259, priority = normal
[20171118 07:20:25.333] IPv6 is installed
[20171118 07:20:25.345] VerifyFileWithHash failed on file /var/lib/resilio-sync//sync.dat with status 4.
[20171118 07:20:25.345] VerifyFileWithHash failed on file /var/lib/resilio-sync//sync.dat with status 2.
[20171118 07:20:25.348] VerifyFileWithHash failed on file /var/lib/resilio-sync//sync.dat with status 4.
[20171118 07:20:25.348] Unsupported or empty sync.dat file
[20171118 07:20:25.348] My PeerID: 1055D9412497BF5ED84FF448003DBB0E04AA25B5
[20171118 07:20:25.348] LC: LoadLicenses: there is no pro license
[20171118 07:20:25.356] loaded history: 1000 events
[20171118 07:20:25.357] Joining to the multicast group 239.192.0.0:3838 on interface 192.168.1.16 (eth0)
[20171118 07:20:25.357] Joining to the multicast group 239.192.0.0:3838 on interface 127.0.0.1 (lo)
[20171118 07:20:25.357] Joining to the multicast group 239.192.0.0:3838 on interface 10.10.50.1 (tun0)
[20171118 07:20:25.357] Create diskio thread for drive with id 18446744073709551614, path: 
[20171118 07:20:25.357] diskio thread start, drive_id = 18446744073709551614, priority = normal
[20171118 07:20:25.358] Debug log mask has been set to FFFFFFFF
[20171118 07:20:25.358] Features mask has been set to 0
[20171118 07:20:25.359] Scheduler: Apply global rule, download limit: -1, upload limit: -1
[20171118 07:20:25.359] CoreState: Total memory: 3079684096, used by Sync: 10387456, percentage used: 0.34
[20171118 07:20:25.359] message thread start
[20171118 07:20:37.582] NAT-PMP: Unable to map port with NAT-PMP.
[20171118 07:20:56.618] OpenSSL: Loaded X509 trusted CA from "/etc/ssl/certs/ca-certificates.crt"
[20171118 07:25:26.491] CoreState: Total memory: 3079684096, used by Sync: 13201408, percentage used: 0.43
[20171118 07:30:27.145] CoreState: Total memory: 3079684096, used by Sync: 13201408, percentage used: 0.43
[20171118 07:35:26.262] CoreState: Total memory: 3079684096, used by Sync: 13201408, percentage used: 0.43
[20171118 07:36:02.480] SRPEH[undefined]: bad shareID (STATE_BEGIN)
[20171118 07:36:02.480] D! 10SyncTcpReq::set_error[0x00007f38100546a0][19] 103 (SyncEncryptHandler)
[20171118 07:36:02.480] D! 10SyncTcpReq[0x00007f38100546a0]: EOF - error: 103 (SyncEncryptHandler)

 

Share this post


Link to post
Share on other sites

Forgot to add.
At the time of shutdown, a complete copy of the virtual machine was made (file vhdx).
So I have a copy of all the files at the time of shutdown.
I tried to replace sync.dat with a file from the copy. But the mistake is the same.
This means the file is corrupted when the Resilio Sync service is stopped.
In the copy, sync.dat is 181KB in size. This means that the file has my settings.
It can be opened with any text editor. Maybe I can somehow fix it?

Share this post


Link to post
Share on other sites

Exact same issue on Ubuntu 16.04.

I have to shutdown all hardware overnight - should I expect to see this across both desktops and laptops tomorrow?

Has anyone spend any time on a fix for this (Windows and/or Linux)?

Share this post


Link to post
Share on other sites

@hexcalibr received your support request.

Update: in this case the problem was in two different processes running on one machine. Not a bug, but simply a confusion between these two. 

 

For all others who "have exact same issue":
1) check that you indeed have only 1 sync process especially on a linux. Check that Sync uses the same storage folder each time you start it. Covers >50% of reports.
2) check that you quit Sync correctly and give it time to save settings. Especially if you've just made some changes to identity - added advanced folders, linked devices, applied license, etc. Especially if you have a lot of sync shares with big database - shutting down will take a while. Don't  do kill -9 or just press power button and don't 'shut down anyway' on windows.  Covers ~45% of reports.
3) Check that you're on today's latest Sync version. Some old version indeed had troubles with saving settings in some cases, all of them are addressed. Covers around 3% of reports.
4) Some other undiscovered issue. With these, please contact support directly, send the debug logs to them and some details about your setup - if there's anything special about it, the pattern for the problem, etc. Thank you. 

Share this post


Link to post
Share on other sites

[censored][censored][censored][censored]!!!!!

Windows reboot normally, Resilio Sync stopped and started gracefully. Aga! Censored!!! 16 TB in 12 shares - lost! New identify asked. [Censored]!!!!

[2017-12-12 19:19:16.005] Stopping network threads
[2017-12-12 19:19:16.958] Stopping UDP threads for 0.0.0.0:25515
[2017-12-12 19:19:17.020] Stopping UDP threads for [::]:25515
[2017-12-12 19:19:17.083] Shutdown. Saving config sync.dat
[2017-12-12 19:19:17.083] diskio thread stop, drive_id = 2
[2017-12-12 19:19:17.083] diskio destroy, drive_id = 2

...... system is rebooting .....
19:22:07.646] Debug log mask has been set to FFFFFFFF
[19:22:07.646] Features mask has been set to 0
[2017-12-12 19:22:07.646] ZIP: Can't locate [version] in zip, error -100.

........sync is staring......
2017-12-12 19:22:07.677] diskio_controller created
[2017-12-12 19:22:07.693] register diskio completion queue with id 1
[2017-12-12 19:22:07.693] PLC[0x000002d57ac58d30] binding on 0.0.0.0:25515
[2017-12-12 19:22:07.693] D! class PeerListenConnection::Socket::listen[0x000002d57ac58d30][1028] bound listening socket 1028 to IP 0.0.0.0:25515
........sync is starting....
2017-12-12 19:22:07.693] Create diskio thread for drive with id 4294981975, path:
[2017-12-12 19:22:07.693] diskio thread start, drive_id = 4294973035, priority = normal
[2017-12-12 19:22:07.693] diskio thread start, drive_id = 4294981975, priority = normal
[2017-12-12 19:22:07.693] IPv6 is installed
[2017-12-12 19:22:07.693] VerifyFileWithHash failed on file C:\Users\resilio_sync\AppData\Roaming\Resilio Sync Service\sync.dat with status 4.
[2017-12-12 19:22:07.693] VerifyFileWithHash failed on file C:\Users\resilio_sync\AppData\Roaming\Resilio Sync Service\sync.dat with status 2.
[2017-12-12 19:22:07.693] VerifyFileWithHash failed on file C:\Users\resilio_sync\AppData\Roaming\Resilio Sync Service\sync.dat with status 4.
[
2017-12-12 19:22:07.693] Unsupported or empty sync.dat file
 

[censored][censored][censored][censored][censored][censored]!!!!! Fcuk! 16 TB dropped nahren. Krivorukie, blin, pogrommisty.

Share this post


Link to post
Share on other sites

Dear Alexander,

Sorry to create the image of krivorukih pogromistov. Can you please contact support with full logs? Your case needs individual investigation. Thank you. 

Please note, that 'identity lost' does not cause deletion of files from drive, if that's what you mean with "16 TB in 12 shares - lost". "identity lost" only causes shares removed from Sync, not files removed from drive. 

Share this post


Link to post
Share on other sites

"does not cause deletion of files from drive" - I KNOW!!

But I need to recreate and re-configure each of 12 shares on 4 other devices,  and resync 16 TB of files. 29 HOURS of FULL HDD LOAD! Censored! Censored!

I try to restore sync.dat (single file and all of resilio AppData folder with all files) from nightly system backup. "Unsupported or empty sync.dat file" again.

Fcuk! 2017, people fly into space and walk on the moon, but neatly write and close the simplest text file with settings - the skills are not enough.

Share this post


Link to post
Share on other sites

If you are not able to do a normal work with the settings file, then make it possible to export-import an individual shares setting into the XML format

XML, JSON, any kind of modern and normal text format, but no your binary! which breaks with each saving

Share this post


Link to post
Share on other sites

Okay apparently I accidentally had two sync processes opened and it resolved after restart. But it would really be great if one could simply edit the configuration file or at least export it, as AL40k suggested.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.