Andy+

DSM 6.0 upgrade says Sync not compatible

Recommended Posts

2 hours ago, RomanZ said:

@poLoNes My bad. ARM build requires /lib/ld-linux.so.3, while ARMHF binary requires /lib/ld-linux-armhf.so.3. Could you please find ld-linux-armhf.so.3 on your DSM and create a symbolic link to it in "/lib"?

This binary does not exist in DSM 6 . :(

Edited by poLoNes

Share this post


Link to post
Share on other sites

Try to run Sync with your existing linker:

/lib/ld-linux.so.3 /usr/local/bittorrentsync/bin/btsync --config /usr/local/bittorrentsync/var/sync.conf

 

Share this post


Link to post
Share on other sites

DS 412+  Updated to Dsm 6.0-7321 and btsync version 2.3.6-1 works using the manual instruction by QuaCKeReD.

Just a note, during the last 2 months when btsync through the package centre wasn't working quite well. The docker version actually works. Would be awesome if the official btsync docker script was kept up to date. Currently still on version 2.3.2.

Share this post


Link to post
Share on other sites

@JSF Thanks for the update. We are working closely with Synology to get back to official package center. We'll also take care to keep docker image up-to-date.

Share this post


Link to post
Share on other sites

@RomanZ Please check the attachment, here you can see what happens. When the machine starts the status of the app is Stopped. I can't start it until I enable the admin account again.

In DSM 5.2 (and before) I never had this issue, the app just started automatically after startup and the admin account was always disabled.

19-4-2016 12-58-54.mp4

idk of the attachments is working, if not: http://nl.tinypic.com/r/2wm1jsl/9

 

Edited by doublelucky
add video link

Share this post


Link to post
Share on other sites

@RomanZ Yes that's right. As many Synology 'tutorials' advise me (even Synology writes it in their How_to_add_extra_security_to_your_Synology_NAS (point 2), page) the first thing I do at a new Synology is create a new admin and disable the default admin. This never caused any troubles until the new DSM update. 

When I enable the admin, the BitTorrent app starts normally, if not it wont start.

Edited by doublelucky

Share this post


Link to post
Share on other sites

@doublelucky Sync is designed to run under default admin, and when it is disabled - it won't run. We'll review if it can be changed in future and run under some other account, but this is how it works for now.

Share this post


Link to post
Share on other sites
On 20/04/2016 at 8:46 PM, RomanZ said:

@doublelucky Sync is designed to run under default admin, and when it is disabled - it won't run. We'll review if it can be changed in future and run under some other account, but this is how it works for now.

@RomanZ I have to agree with @doublelucky the security reduction in enabling the default admin (even with a changed, 32 character complex password) is really frustrating, especially considering it worked in DSM 5 without it enabled. If it can be looked at to create its own account, or use one specified by the users so I can then limit its permissions and re-disable the admin account that would be great.

Share this post


Link to post
Share on other sites

May i know if this issue is being resolved? We have deployed many DSM+BTSync but now still running DSM 5.2 because it is not working. Hope to get a fix from Synology or Sync soon.

Share this post


Link to post
Share on other sites

@JSF Docker image with Sync 2.3.7 is now publicly available - JFYI.

@jpsimmonds I wouldn't call it security reduction. Syno was working just fine with admin allowed till DSM5.2. They are improving their security by disabling admin. Though, we are aware of it and will definitely check the possibility of moving Sync from admin account.

@David Loke We are working to get back to official store. So, if under "this issue" you  mean the message that Sync is not compatible - no, it is not yet resolved. Although, if you need to get your Sync working on DSM6 you can simply grab Sync package here and manually install it.

Share this post


Link to post
Share on other sites

Hi I have run into the same issue- Synology wants me to upgrade from 5.2 to 6.0 but I am dependent on Bittorrent Sync.

 

@RomanZ that link that you provided doesn't seem to work for me- I get an "Oops" error.

 

What is the recommended procedure to update my Synology DS213 (MARVELL Kirkwood 88F6282) to DSM 6.0 while still having a Bittorrent Sync client on it?

Share this post


Link to post
Share on other sites

Hi, I managed to upgrade to DSM 6 from 5.2 and install resilio 2.4.1-1 manually. But now all the sync folders are gone... how do i get them back? I do not want to recreate them because they are huge and the indexing will be a pain. Please advise.

Share this post


Link to post
Share on other sites

May I know if the index will recognise the files and not duplicate them? Coz the last time when i move the files from 1 folder to the other, all files got duplicated at all storages.

Any more detailed HOW-TO for this?

Share this post


Link to post
Share on other sites
On 9/19/2016 at 10:31 PM, Helen said:

@infomofo,

here's the new link.  If you need 2.3.8, let me know. 

As you can see from this forum topic, you can go ahead and update. 

 

Hit a roadblock. It says that "This package does not contain a signature". I've checked that the package and CPU is correct. Did i miss out anything? 

Screen Shot 2016-12-25 at 12.46.12 PM.png

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.