Can't reach Resilio on QNAP


wus
 Share

Recommended Posts

Hello everyone,

I have a problem with Resilio syncing between my Windows PC and my QNAP NAS. According to the App Center on my TS-251+, Resilio Sync 2.7.1.1370 is installed, but when I try to open it, I get an error message "Firefox can't establish a connection to server (my NAS's IP address):14860".

How can I get control over it again?

Link to comment
Share on other sites

I updated the QNAP O/S, after that I could connect to Resilio Sync as I used to.

But unfortunately, this worked only once. When I tried again, I got the error message again.

Then I restarted the NAS once more because I thought, maybe it works again afterwards (even if only once), but it didn't.

Link to comment
Share on other sites

Thanks for reminding me of this. I updated to the 2.7.2.1375 now. After the update, I was able to open Resilio on the NAS. It was working there for about 1 minute, then darkened the browser window, showing

"Sync Home has stopped responding. Try reloading the page, or restart the Sync Home instance you were connected to."

I first tried to reload the page, this resulted in the error message that I reported above: "Firefox can't establish a connection to server (my NAS's IP address):14860"

Next I stopped Resilio from the NAS's App overview, and started it again after a short wait. After that, I could connect to Resilio again. This time it did not stop responding after a minute. I hope it keeps working continuously now, and succeeds to finally sync a newly added subdirectory that I created recently, to my PC's harddisk.

Link to comment
Share on other sites

Doe you analyse any logs and other files? Doe you have enough space on storage and also enough RAM? How much peers you have with which no. of files and folders? Because it seems that Resilio starts normal, but doesnt run continously because of other reasons.

Fragments means, after de-installation there are maybe a rest of any files from Resilio, you delete manually.

Link to comment
Share on other sites

I have 4 GB RAM in the NAS, which are currently - and typically - used only to around 28 or 30%. Storage is occupied with 9.82 TB to around 80%, with 2,44 TB still available.

At present, only 1 peer is on, but there could be up to 3 if my other devices are running or in the LAN. There are currently 62 folders to sync, some are small with only a few small files and sync only to one of the possible peers, others can contain subdirectory structures up to 6 levels deep, several 10,000 files and several 100 GB and sync to 2 or all of the peers, if they are online.

So far I have not analyzed any Resilio logs, from former tries to look into some (on the PC, not on the NAS) I vaguely remember that I did not understand really them. Where would I find Resilio log files on the NAS?

 

Link to comment
Share on other sites

  • 6 months later...

Dear all!
We suspect that there is an issue with async disk operations that leads to Sync crashing. The suggested way to prevent it from happening is adding "async_io" : false, line to resilio-sync.conf file, like this (please mind the syntax):

?name=async_io-false.png

To find the absolute path to the file, run the following command in the terminal (Sync must be running)
ps aux | grep rslsync | grep -v grep

Prior to editing of the config, stop Sync.

Link to comment
Share on other sites

Hello,

I am also having the problem with the app crashing again and again.
Unfortunately my technical skills to change the config file are not sufficient, as I am not familiar with Linux/terminal.

Do you plan to release a fixed version soon, so that the app will be usable again?

Regards
Mark

Link to comment
Share on other sites

  • 2 weeks later...
On 5/11/2021 at 5:59 PM, alberto said:

Me too! Same problem with TS 451+ and 16 Gb RAM.

I'm not familiar with terminal and I don't even know where it is resilio-sync.conf file.

So solve this problem please!!

Regards

Alberto


It's very simple.

Go to the QTS Webinterface, open the App Center, stop Resilio Sync.

Activate SSH on your NAS, install Putty, enter the IP of your NAS, Port 22 and press connect. Enter as admin. Go to the normal shell.

https://www.qnap.com/en-us/how-to/knowledge-base/article/how-to-access-qnap-nas-by-ssh

cd /share/CACHEDEV1_DATA/.qpkg/ResilioSync/

There it is, edit it with

vim resilio-sync.conf

Press i to enter the INSERT mode and edit the file. Press ESC to exit the mode, type

:wq

to exit and save the file. Restart Resilio Sync from the App Center.

The solution from Resilio seems to have it solved for me, 

Link to comment
Share on other sites

  • 4 weeks later...

Unfortunatly, I can't to this changes via SSH because for this, QTS needs the user "admin" and I have problems with passwordfor this user and password reset isn't working.

So a proper solution (updated version of Resilio) is urgently needed!

Link to comment
Share on other sites

On 5/16/2021 at 11:27 PM, Frank Maier said:


It's very simple.

Go to the QTS Webinterface, open the App Center, stop Resilio Sync.

Activate SSH on your NAS, install Putty, enter the IP of your NAS, Port 22 and press connect. Enter as admin. Go to the normal shell.

https://www.qnap.com/en-us/how-to/knowledge-base/article/how-to-access-qnap-nas-by-ssh



cd /share/CACHEDEV1_DATA/.qpkg/ResilioSync/

There it is, edit it with



vim resilio-sync.conf

Press i to enter the INSERT mode and edit the file. Press ESC to exit the mode, type



:wq

to exit and save the file. Restart Resilio Sync from the App Center.

The solution from Resilio seems to have it solved for me, 

 

Seriously - you think that's "very simple" - ???

Link to comment
Share on other sites

On 4/28/2021 at 4:44 PM, Daria said:

We suspect that there is an issue with async disk operations that leads to Sync crashing. The suggested way to prevent it from happening is adding "async_io" : false, line to resilio-sync.conf file, like this (please mind the syntax):

?name=async_io-false.png

To find the absolute path to the file, run the following command in the terminal (Sync must be running)
ps aux | grep rslsync | grep -v grep

How do you do that when Sync ever runs only for a minute or 2???

 

I stopped using Sync now, use FreeFileSync now. It does not even require an agent on the NAS.

Link to comment
Share on other sites

  • 1 month later...
  • 2 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share