mbob

Ms Office: Don't Have Permission To Write To The Selected Folder

Recommended Posts

I can confirm that this issue still happens for me with MS Access too.  To test, set up a sync containing an Access database, open the database, then choose to compact it.  Usually, on the first occasion, it just fails.  If you persist them sometimes the process gets interrupted at a critical point and stranger things can happen.  I have also had to resort to a backup before, although it's been a while.  Now I make sure that I close sync before compacting :(.

Share this post


Link to post
Share on other sites

@lupus, @Hopkins

While we investigate issue with MS Access in our lab, you may try the following workaround:

 

- Close Sync

- Open "FileDelayConfig" file (resides in %appdata%\BitTorrent Sync)

- add the following text to the end, before trailing "}":

, "​*.accdb": 10, "*​.laccdb": 10, "​*.mdb": 10, "*​.ldb":10

Pay attention to the leading comma and the fact that no commas should be before closing curly bracket.

- Launch Sync. See if issue still happens.

Share this post


Link to post
Share on other sites

@all

We've managed to reproduce (thanks to @lupus) and fix the issue. Please expect fix in next major release. I'll update thread once it is out.

Share this post


Link to post
Share on other sites

Many thanks - I look forward to helping to test.  I'm sorry that I did not respond to the last requests - they arrived at a particularly busy time and ended up getting buried in other issues which required my time.

Share this post


Link to post
Share on other sites

the problem is not solved....sorry to say that. if the process of compressing the access-database needs more time (for example 1 second), i have the same error-message like ever.

Share this post


Link to post
Share on other sites
7 hours ago, lupus said:

the problem is not solved....sorry to say that. if the process of compressing the access-database needs more time (for example 1 second), i have the same error-message like ever.

Have you tried making the FileDelayConfig changes RomanZ previously suggested? If so, have you tried increasing the delay values for your Access file types? - For more information, please see this Help Center article.

Share this post


Link to post
Share on other sites

@lupus That's rather strange. Since 2.3 we are using very special API which allows us to detect the fact that file is busy without actually opening it (and, as a result, preventing Access or other apps from opening files for exclusive use). I'll send you instructions in PM on how to debug.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.