Recommended Posts

Thank you Jimmy and hurik


I am not a Unix expert so I am really struggling.


Jimmy, I have created a shared folder in /volume1:

drwxrwxrwx    2 root     root          4096 Oct  8 23:12 BTsync_john


But damn again when I try to add a sync and ask BTsync to point to /volume1/BTsync_john I get the f$# same message! No right to do so!


Hurik I have tried to edit my passwd file but failed miserably.


I can't even make a backup copy (just in case) nor use the sudo mode... Sorry but I am close to zero in Unix skills...


DiskStationJohn> cp passwd passwd.old

cp: can't create 'passwd.old': Permission denied

DiskStationJohn> whoami


DiskStationJohn> sudo cp passwd passwd.old

-sh: sudo: not found

DiskStationJohn> sudo su

-sh: sudo: not found


My passwd looks like this:

btsync:x:100:100:BitTorrent Sync User:/usr/local/btsync/var:/bin/sh


Help much appreciated.



Share this post

Link to post
Share on other sites



Do you (or anyone else here) know where this issue comes from? I have this on 2 of my DS213 every few days. btsync crashes and I have to restart it.



[20141007 10:43:34.920] KickSocketObj::set_error(err=101, socket_error=false): : Network is unreachable

[20141007 10:43:34.926] UPnP: Device error "": (-2)
[20141007 10:43:34.952] KickSocketObj::set_error(err=101, socket_error=false): : Network is unreachable
[20141007 10:43:34.954] KickSocketObj::set_error(err=101, socket_error=false): : Network is unreachable

Share this post

Link to post
Share on other sites


Is there a way I could create a btsync user and somehow link it to btsync service?

For my manual installation of btsync, I naturally had to create a btsync user. I only ever start the btsync process while logged in as that btsync user, launching the binary that lives under that user's home directory. So of course that btsync user owns the process, and everything else runs correctly, with no access or permission errors. If you're suggesting somehow attaching a new user to the community package's process, I suppose there must be a way to finagle permissions, but I suppose you'd have to be confident you know every single thing that the process accesses, which I wouldn't be. So I wouldn't want to mess with any confusions arising from that hybrid situation. I believe I did once try the community package and then bailed when it didn't give me enough control, particularly for updates and reverting. There was a manual installation guide available, so that's how I've always done things.

Share this post

Link to post
Share on other sites

Just had this issue on a running system (Synology DS411+ii), immediately after upgrading to 2.0.105-1.


Tried several things to resolve (disconnect/reconnect, chmod on root folder, etc), but none worked.  So I set about looking at the differences between the folders that were showing this error, and the ones that weren't.  And found one thing that seems to have fixed this for me;


The hidden .sync folder on these issue folders had following owners;

  drwxrwxrwx    3 100      superuse      4096 May 21 17:00 .sync

and on non-issue folders;

  drwxrwx---    3 100      users         4096 May 21 15:27 .sync


NB; superuse is a group I setup, of which admin and myself are members


The main problem, I saw here was the group ownership - users vs superuse - though the user owner (100, an unknown user, though I believe was the older btsync user, no longer used so deleted) seemed to be an issue.


Updating the ownership on the .sync folder to 100:users resolved the issue immediately!

And, as btsync runs as admin now, updating to admin:users didn't cause any issues.

Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.