Recommended Posts

Hi,

We would like to create a list of NAS modeles that is supported by Sync. If you started Sync on Nas, please respond to this topic.

Sync confirmed to be running on:

Synology: Ds110j, Ds210j. DS211j, DS213+ (custom build), DS211, DS411j, DS712+, DS713+, DS411 slim, DS-411+,DS411+II, DS412+

QNAP: TurboNAS TS-459 Pro II, TS410, TS-212, TS219, TS-110, TS412, TS-210,

Western Digital: MyBook Live WDBACG0020HCH-00

iOmega: IX2-200

ZyXel: NSA310б NSA-221

D-Link: DNS-320

Raspberry Pi

Doesn't work on

DLink NAS DNS-323

Please provide installation steps, this will significantly help other users.

Share this post


Link to post
Share on other sites

I don't know why Synology uses so old libc. we need newer one to use ionotify, to have realtime information about changed files. We will look to the option to release a build without ionotify, directory will be rescanned every n seconds. Then we will run on older versions.

Share this post


Link to post
Share on other sites

Synology DS1010+ Not OK. (DSM 4.2 Beta)

Synology DS508 Not OK. (DSM 4.0 - Latest)

Also Libc Issues.

I can test with a statically compiled version of SyncApp if you want. I believe this will circumvent the libc problems altogether, howevery I'm not sure about that.

I've also looked into the possibility of upgrading my libc on the synology. Luckily it was my test system, things broke beyond repair. Had to reinstall.

Share this post


Link to post
Share on other sites

We do have statically compiled libc, however it needs to be supported by OS. In this case OS does't support it. We will look to option to disable ionotify to support older versions. But it seems we will need support from you in testing all variations, since it we won't be able to test all combinations.

Share this post


Link to post
Share on other sites

I have been trying to get the SyncApp working on my Synology DS-712+, but as it seems to be a well known issue, this is running with a somewhat old version of GLIBC.

Today i've been giving it a go at compiling version 2.4, but it seems to be not as easy as one could have hoped for.

I will try to keep looking for a solution, undtil a upgraded ipkg package becomes available to support the CPU in the DS-712+

Share this post


Link to post
Share on other sites

Waoo. Simple. Beautiful.

Successfully installed and tested sync on 2 Synology NAS DS712+ and DS713+ (both x86_64).

Special "sync synology build 1.0.116".

Worked like a charm between 2 optical fiber connections, each capable of uploading @50mb/s

As I ran merly 5.5MB/s, eg. around 40 mb/s, i guess the protoocol is working great :)

Continue testing but this sounds very promising.

Share this post


Link to post
Share on other sites

How do you install BitTorrent Sync on a Zyxel NAS device?

Could you try to contact trikerman, he installed it on Zyxel?

Share this post


Link to post
Share on other sites

I was able to get this working with my Zyxel NSA-221.

1. InstappFFP - http://zyxel.nas-cen.../wiki/FFP-stick - this must be installed and setup first.

2. Copy btsync file that is located in the ARM compressed file to /ffp/bin using telnet. - http://syncapp.bitto...sync_arm.tar.gz

3. Create file /ffp/start/btsync.sh with the following text- this is to make it auto start when the NAS is rebooted.


#!/ffp/bin/sh
/ffp/bin/btsync

Then make btsync.sh executable with chmod.


chmod u+x /ffp/start/btsync.sh

Hope this helps someone

Eddie

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now