lequick

Out Of Sync

Recommended Posts

> Just to be absolutely precise - all secrets you use are starting with "A..." and "B..." and none - with "D...", "E...", "F...", right?


 


Sorry I waited to answer : yes they all begin with A.


-------------------------------------------------------


I upgraded The two PC to 1.4.99


The Android Phone to 1.4.56


 


The problem I described previously doesn't seem to occur anymore: the data I put on the PCs are copied in one shot to the phone.


Share this post


Link to post
Share on other sites

Are you using Encrypted nodes? - As I say, 1.4.99 fixes "Out of sync" issues with encrypted nodes

 

Do we need to add the folders again on all clients? Or can we just update the clients?

Share this post


Link to post
Share on other sites

 

@mumen

We'll need your debug logs from all your peers affected the "out of sync" issue.

 

@RomanZ

 

I upgraded The two PC to 1.4.99

The Android Phone to 1.4.56

 

The problem I described previously doesn't seem to occur anymore: the data I put on the PCs are copied in one shot to the phone.

 

 

Oui?

Share this post


Link to post
Share on other sites

@all, if you're experiencing an "Out of sync" issue with Encrypted peers, then version 1.4.99 contains a fix for this particular issue

I don't know what an encrypted peer is but I installed this on one of my machines and they all seem to be syncing correctly now! Thanks!

Share this post


Link to post
Share on other sites

I have this too although maybe slightly different.

I went to sync a directory with data on it (both the same for 99%) and lots of files aeound 30K.

 

What it looks to me is that in 1.4.99 BTsync checks it's hash directly with the other file and can only do that 100x each 5 minutes. Why doesn't btsync just checks it's files on the new machine locally by the sync data between the two clients?

 

For instance A has 3000 files B has 2990 of them. A sends it's filelist info(with the hashes to B ) B reads the hashes locally and checks them with it's own filelist. B marks the ones that are different and request those files from A.

 

Now A just sends 100 hashes to B, B checks them and if all are good it waits 5 minutes till the next set comes.

Edited by Hakker

Share this post


Link to post
Share on other sites

Are all file in sync when this process finishes? I had the same experiences, when I removed a folder from sync and then re-added. A few hashes were verified (not much outgoing traffic), then the process stopped and a few minutes later it continued.

 

It's not that great to wait a few hours for 2 peers to show up "synced" status, if they were in sync before and you just re-added them. But this should usually be a one time process for the very first time sync runs on that peer, so it was okay for me to wait.

 

Anyway of course it would be interesting to know why this takes so long.

Share this post


Link to post
Share on other sites

@Hakker

This is something Sync actually does (roughly). Though note, that it takes time to read 3000 files and hash them.

 

@ICE

When you re-add the folder, Sync completely "forgets" about all the files and adds them from scratch. And to do so - it needs to hash all of them. If sync does it way slower than HDD bandwidth (usually it is limited by HDD read speed, as CPU is powerful enough to hash data much faster than read from drive) - it looks to be a bug and to be investigated. Otherwise - it is app design.

Share this post


Link to post
Share on other sites

@all - some further cases where files were not syncing ("out-of-sync") have been addressed in today's 1.4.103 build.

If you're still experiencing "out of sync" issues, please update and see if this resolves your issue.

Share this post


Link to post
Share on other sites

Also found that:

1. If totally delete share folder from RO node (remove files) and try to sync from scratch than everything will be OK. But if after such sync You'll delete share from BTSync on RO node and will try to sync it from master to same folder - it will be Out of sync.

 

2. If there is one share with "real" Out of sync then all other "good" shares will be Out of sync at the end. If You'll delete that "real" Out of sync share, than other "fake" Out of sync folders will sync OK in a couple of minutes/seconds.

 

Seems like there is limited number of file sync slots (it was 100 in previous versions and 180 now) and if every slot used by "bad file" that can't sync for any reason (or without it like in 1.4.* :( ) than there will be Out of sync error on any share folder.

If slots count is more that "bad files" than those "bad files" will be set to another slots after timeout and everything could be OK - that's why Out of sync problem sometimes can be solved  after lots of hours of wait.

 

Also there is a temporary (for couple of seconds) Out of sync state when file with other than btsync process owner appears.

 

BTW!!! Noticed such error in log:

[20141112 02:59:50.615] 31.42.4x.xx:45039: did not pick any blocks. blocking peer temporarily

[20141112 03:00:30.644] 31.42.4x.xx:45039: did not pick any blocks. blocking peer temporarily
 

This IP is set as my master node on slave node shares. So if You'll block it, than it can cause "Out of sync"!

 

 

OS Linux, CentOS 6.5. Master x64, Slave (RO) x86

Share this post


Link to post
Share on other sites

2d7eaag.png

Issue with this setup. Currently restarting does not resolve this issue

 

-Mutantx

 

Same issue still present with 1.4.103 beta on both devices.  Fresh add of RO key to new folders on both devices.

 

-Mutantx

Share this post


Link to post
Share on other sites

@b0rman

 

1. Yes, "Overwrite changed files" set
2. OK, may I'll send logs soon
3. Yes. VPN channel is set to connect to local IPs only.
4. Why? At same moment ping is stable, speed with simple scp (rsync) is 25Mbps and more.

 

1. Any files are shown in sync queue (see peers list window)?

2. Cool.

3. Okay, does remote peers has local IPs from the same IP range as your peer? If yes - it still will attempt to connect them directly.

4. I suggest checking that the ports configured as "Listening" are not blocked by firewall. Also, are there any mobile devices involved? They process approvals slightly different.


@Mutantx

Do I understand correctly that your Linux and Win peers cannot sync the photo backup folder between them? Or some other folder keeps to be "out-of-sync" when iPhone is disconnected?

Share this post


Link to post
Share on other sites

I have updated to 1.4.103, but I have this "out-of-sync" problem when trying to resync readonly folder.

 

I have two computers working under Windows 7, syncing a folder, size over 1500 gigabytes.

 

Computer A has master-key, computer B has no key currently and I want to give it read-only key. (that situation appears because of OS reinstalling). Both comuters have now currently similar folders, I just want to connect them again.

 

But when I add a read-only key to computer B, it recieves data for 5-15 seconds, after this it freeze for 1-2 minutes with "out-of-sync" status.  Then again getting data for 5-15 seconds and all over this circle.

 

At the same time, first time synchronise works normal.

 

Do you need my logs to fix this?

Share this post


Link to post
Share on other sites

The latest updates have solved every out of sync issue I've had on OS X *except* the readonly folders others have mentioned.  I have one very large one, terabytes in size, that used to sync well.  In fact, it does seem to sync okay, new content is added to the readonly node, but it never gets a green checkmark and will say out of sync with no nodes available.

Share this post


Link to post
Share on other sites

Extremely slow sync because of Out of sync on RO shares. Servers on same LAN with 1Gbps can't sync 8GB of share in one node. Even on Windows now :(

 

Where is windows log file?

Share this post


Link to post
Share on other sites

@Finar, @smajor

Could it happen that your target RO folder has files that are different that original folder? In this case RW folder is going to get "Out-of-sync" status. It can be easily solved with setting "Overwrite changed files" preference in folder preferences.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.