ng_4r

[Solved] Bt Sync 2.0 Preventing Sleep On Mac Os X (10.9)

Recommended Posts

Since I upgraded to BT Sync 2.0 it's preventing sleep on my two machines, a mini and a macbook pro.

This wasn't happening with the 1.4 beta version.

 

Here is the results from pmset in Terminal, with Sync opened:

 

 

pmset -g assertions

09/03/15 16:45:05 CET    

Assertion status system-wide:

   BackgroundTask                 0

   PreventDiskIdle                0

   ApplePushServiceTask           0

   UserIsActive                   1

   PreventUserIdleDisplaySleep    0

   InteractivePushServiceTask     0

   PreventSystemSleep             0

   ExternalMedia                  0

   PreventUserIdleSystemSleep     1

   NetworkClientActive            0

Listed by owning process:

   pid 2231(BitTorrent Sync): [0x0000000100000970] 00:01:02 PreventUserIdleSystemSleep named: "syncing" 

   pid 71(hidd): [0x0000000a000008da] 05:38:01 UserIsActive named: "com.apple.iohideventsystem.queue.tickle" 

Kernel Assertions: 0x10c=USB,BT-HID,MAGICWAKE

   id=502  level=255 0x4=USB mod=08/03/15 12:32 description=EHC1 owner=AppleUSBEHCI

   id=504  level=255 0x8=BT-HID mod=01/01/70 01:00 description=com.apple.driver.IOBluetoothHIDDriver owner=BNBMouseDevice

   id=505  level=255 0x100=MAGICWAKE mod=09/03/15 16:48 description=en0 owner=en0

 
And without Sync running:
pmset -g assertions

09/03/15 17:21:50 CET    

Assertion status system-wide:

   BackgroundTask                 0

   PreventDiskIdle                0

   ApplePushServiceTask           0

   UserIsActive                   1

   PreventUserIdleDisplaySleep    0

   InteractivePushServiceTask     0

   PreventSystemSleep             0

   ExternalMedia                  0

   PreventUserIdleSystemSleep     0

   NetworkClientActive            0

Listed by owning process:

   pid 71(hidd): [0x0000000a000008da] 06:14:46 UserIsActive named: "com.apple.iohideventsystem.queue.tickle" 

Timeout will fire in 677 secs Action=TimeoutActionRelease

Kernel Assertions: 0x10c=USB,BT-HID,MAGICWAKE

   id=502  level=255 0x4=USB mod=08/03/15 12:32 description=EHC1 owner=AppleUSBEHCI

   id=504  level=255 0x8=BT-HID mod=01/01/70 01:00 description=com.apple.driver.IOBluetoothHIDDriver owner=BNBMouseDevice

   id=505  level=255 0x100=MAGICWAKE mod=09/03/15 16:53 description=en0 owner=en0

 
as you can see "PreventUserIdleSystemSleep 1" is caused by BitTorrent Sync.
 
How could I avoid this?
Is there a specific line in the advanced preferences to edit?
 
If it's not a real problem with my laptop, because I'm used to close the lid when not using it, it's a little bit more annoying with the desktop computer because I'm forced to quit the app when not using that computer or hit every time "Stop" from the Apple menu.
 
Any solution/suggestions?

 

Share this post


Link to post
Share on other sites

Same problem on Windows 8.1. Since I updated to 2.0 my primary machine's monitors won't sleep due to inactivity as they should.

Share this post


Link to post
Share on other sites

Check that the following advanced preferences are set at higher intervals than the idle interval your OS is set to sleep after:

 

config_refresh_interval (seconds)

config_save_interval (seconds)

folder_rescan_interval (seconds)

 

Also ensure that Sync's debug logging is disabled.

Share this post


Link to post
Share on other sites

Thanks for your response. I've tried several times to reduce the idle interval to minimum (2 minutes) in order to see quickly my machines reaction. It's the same that set that three advanced preferences to a value higher than idle interval. Is it right?

 

However it didn't work... tomorrow I'll try to monitor one of the machines using your tip, even if I think is the same then lower idle interval.

 

Could it be due to something else?

 

Another question: setting those preferences at higher interval means that rescan will happen slower then how it operates now, isn't it? I like to see fast sync, because lot of the times I switch between them and I'd like to have things synced fast as now.

Share this post


Link to post
Share on other sites

Absolutely not working: I've tried to set to a higher level (1800 sec - 30 min) while my computers have to stop at 5 minutes.

It seems to be a bug.

Other suggestions? Is it possible  to avoid this situation in another way, not quitting BT Sync app?

Share this post


Link to post
Share on other sites

Same issues here.

Have BTS 2.0 running on my Mac Mini which should sleep until anyone requests something (WOL). Since BTS 2.0 i see the same entries in pmset -g assertions causing the Mac to stay awake.

 

 

So it's mentioning that it's preventing sleep because of "syncing" but BTS is not syncing activly as all folders are synced. Of course I would want to leave the mac awayke while syncing but not in idle mode.

 

I believe it's a bug in BTS 2.0 which does not "reset" the value in pmset after syncing? Or whatever. Anyone knows where to report bugs officially?

Edited by toastedtoast

Share this post


Link to post
Share on other sites

Check that the following advanced preferences are set at higher intervals than the idle interval your OS is set to sleep after:

 

config_refresh_interval (seconds)

config_save_interval (seconds)

folder_rescan_interval (seconds)

 

Also ensure that Sync's debug logging is disabled.

 

Disabling debugging logging worked for me on Windows. Also, ensure you're using the latest 2.0.85 build.

Share this post


Link to post
Share on other sites

I don't have debug enabled on OS X.

I've tried to enable it, quit the app, re-launch and disable then quit and re-launch it again... Always preventing sleep.

 

This is definitely a BUG....


Same issues here.

Have BTS 2.0 running on my Mac Mini which should sleep until anyone requests something (WOL). Since BTS 2.0 i see the same entries in pmset -g assertions causing the Mac to stay awake.

 

 

So it's mentioning that it's preventing sleep because of "syncing" but BTS is not syncing activly as all folders are synced. Of course I would want to leave the mac awayke while syncing but not in idle mode.

 

I believe it's a bug in BTS 2.0 which does not "reset" the value in pmset after syncing? Or whatever. Anyone knows where to report bugs officially?

 

Have you reported it or find out how to? 

Share this post


Link to post
Share on other sites

@all, 

 

This is already in work with developers. 

For windows, what do you get in "powercfg -requests" output in Admin's Command Prompt?

Share this post


Link to post
Share on other sites

@all, 

 

This is already in work with developers. 

For windows, what do you get in "powercfg -requests" output in Admin's Command Prompt?

Here's what I get (running 2.0.93, Windows 7 x64 & 8.1 x64 machines idling and sleeping correctly):

ofS9cvU.png

Share this post


Link to post
Share on other sites

@Helen

 

Thanks for your response, I hope there will be a fast resolution.

In this situation I'm simply launching the app on the two machine when I need to transfer things and quitting when done. It's not to bad to me but a step by step sync at every change could be better.

Do you think it could be fixed within next update? when is planned to be released?

Share this post


Link to post
Share on other sites

Mac is still under investigation, but we cannot reproduce it for Windows. 

 

@jdrch,

Thank you, but do I get it right and Sync is not on the list? 

 

Anyone who has this problem with Windows, Sync preventing it from sleep, any details? At least "powercfg -requests" output? 

Share this post


Link to post
Share on other sites

BTS 2.) is preventing my MacBook Pro from sleeping after default interval on OSX 10.10.2...here is the pmset output:

 

Active Profiles:

Battery Power 1

AC Power -1*

Currently in use:

 standbydelay         10800

 standby              1

 womp                 0

 halfdim              1

 hibernatefile        /var/vm/sleepimage

 darkwakes            1

 gpuswitch            2

 networkoversleep     0

 disksleep            10

 sleep                1 (sleep prevented by BitTorrent Sync)

 autopoweroffdelay    14400

 hibernatemode        3

 autopoweroff         1

 ttyskeepawake        1

 displaysleep         10

 acwake               0

 lidwake              1

 

Share this post


Link to post
Share on other sites

sgmiller,

 

Thank you. The problem with Mac is known to us and seems to be already fixed. Fix will be available ASAP.

As for windows, details from your machines are still welcomed, as we still cannot reproduce it. Thanks! 

Share this post


Link to post
Share on other sites

BTW....I can can confirm that with BTS closed, all sleep issues on my system are resolved so, once again, look forward to the update so I can back to running BTS as intended.

Share this post


Link to post
Share on other sites

I notice that an update just came out with no fix for the sleep issue....is the fix coming in the near future? 

 

This is a serious issue which prevents me from using BTS properly and I have paid for a license.

Share this post


Link to post
Share on other sites

Still seeing this with 2.0.105 running on OS X 10.10.3. According to "peset -g assertions", BitTorrent Sync is preventing system sleep. I turned off debug logging, since some people mentioned that, and relaunched the app. No change, though.

Share this post


Link to post
Share on other sites

I am getting increasingly irritated that there is no fix for this issue. How am I supposed to leave  BTS running if it prevents my MBP from sleeping? This is interfering on a number of different levels as so completely prevents the intended use of the app. As I have said before, I am one of those who actually paid for a license which adds to the irritation.

 

I don't see any reason why a fix for the issue along cannot be made available unless there actually is not fix?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.