Recommended Posts

There is no "install" in UNIX. Just place the btsync binary where you like, along with its config file and all of the meta cache it has already created since you've run it in tmp already.

Then add a startup line to /etc/rc.conf.local (FreeBSD) or /etc/rc.local (Linux).

I have the btsync binary in:

/usr/Appdata/bitTottentSync/

nano rc.local

added

/usr/Appdata/bitTottentSync/btsync.sh

saved (reopened to make sure)

I can ./btsync and it runs and I can configure.

On reboot it is still in the directory but it does not load.

Share this post


Link to post
Share on other sites

It's not a shell script, not is the binary named that way. So why did you add the .sh to the filename in your init script? And don't forget to specify the config file maybe?

And you didn't specify the absolute path to your rc.local so make sure you're editing the file in the correct place. Usually it's /etc/rc.local and the file should already exist.

Share this post


Link to post
Share on other sites

It's not a shell script, not is the binary named that way. So why did you add the .sh to the filename in your init script? And don't forget to specify the config file maybe?

And you didn't specify the absolute path to your rc.local so make sure you're editing the file in the correct place. Usually it's /etc/rc.local and the file should already exist.

I took off the .sh and it is running on reboot.

Yes, it was the /etc/rc.local file that I modified.

Now I can goto ipaddress:8888 and see the config screen but the files are not syncing.

I changed the owner of btsync to root:root, rebooted but still no sync.

I even re-added the folder with no luck.

Share this post


Link to post
Share on other sites

I took off the .sh and it is running on reboot.

Yes, it was the /etc/rc.local file that I modified.

Now I can goto ipaddress:8888 and see the config screen but the files are not syncing.

I changed the owner of btsync to root:root, rebooted but still no sync.

I even re-added the folder with no luck.

I added sleep 3m && /usr/Appdata/bitTorrentSync/btsync

to the rc.local file.

Now on reboot it loads and I'm Syncing as I type.

So it works with a Seagate GoFlex Home 2tb NAS.

Thank you,

Craig

Share this post


Link to post
Share on other sites

I want to try the Synology DS213+ but I see no reference to to Quorig build for Synology except the initial reference to a custom build at the top of the post and other posts which make me wonder if the current Quorig build works for Synology. This all being way (way) outside my experience can anyone let me know which if any files I should try or do I need to wait for a Synology specific release? If anyone has already done it a step by step command list would be great too. Thanks

Share this post


Link to post
Share on other sites

Hi,

We would like to create a list of NAS modeles that is supported by Sync. If you started Sync on Nas, please respond to this topic.

Sync confirmed to be running on:

Synology: Ds110j, Ds210j. DS211j, DS213+ (custom build), DS211, DS411j, DS508, DS712+, DS713+, DS411 slim, DS-411+,DS411+II, DS412+

QNAP: TurboNAS TS-459 Pro II, TS410, TS-212, TS219, TS-110, TS412, TS-210,

Western Digital: MyBook Live WDBACG0020HCH-00

iOmega: IX2-200

ZyXel: NSA310б NSA-221

D-Link: DNS-320

Raspberry Pi

Doesn't work on

DLink NAS DNS-323

Please provide installation steps, this will significantly help other users.

Hi,

could you check to generate a package to use it on OpenWRT (linux firmware used on many routers and that could be used as NAS) : http://forum.bittorrent.com/topic/19462-how-to-sync-folder-between-openwrt-router-external-hdd-and-computers-linuxandroid/

Here is the list of existing package on OpenWRT that could perhaps be used and then just need some settings (then explain it is this automatic folders sync) :

http://downloads.openwrt.org/backfire/10.03.1/brcm47xx/packages/

Sincerely thanks and have a nice day,

Miguipda ;-)

Share this post


Link to post
Share on other sites
Sync confirmed to be running on:

Synology: Ds110j, Ds210j. DS211j, DS213+ (custom build), DS211, DS411j, DS508, DS712+, DS713+, DS411 slim, DS-411+,DS411+II, DS412+

Hi,

Strange, I have a DS508 and impossible to install, I get this error message:

./btsync: /lib/libc.so.6: versionGLIBC_2.4' not found (required by ./btsync)

It seems that a lot of user with a PPC CPU have the same problem.

I installed without problem on a DS1812+, DS212j, DS411+II but not on the DS508...

Can you please tell me what build work on DS508 or where did you see that it work on this model?

Thank you

Share this post


Link to post
Share on other sites

Working on Linksys NSLU2 running Debian squeeze.

I used a 16 GB USB stick, and followed this installation guide:

http://www.cyrius.com/debian/nslu2/unpack/

And followed this guide to install btsync:

http://forum.bittorrent.com/topic/18974-debian-and-ubuntu-server-packages-for-bittorrent-sync/

I used the NSLU2's 100BaseT outlet and the smb (Samba) protocol for mounting Network drives for syncing.

Share this post


Link to post
Share on other sites

D-Link 321 not working

./btsync: relocation error: ./btsync: symbol __res_iclose, version GLIBC_PRIVATE not defined in file libc.so.6 with link time reference

Linux p0larClone 2.6.22.7 #15 Mon Aug 10 17:41:46 CST 2009 armv5tejl unknown

Share this post


Link to post
Share on other sites

Qnap TS-659 Pro II is working fine.

Just unpacked and started.

No problems whatsoever.

BTW: I'm planning to get a D-Link DIR-300 router and use DD-WRT (linux-based os) on that device.

Since the router can work as a NAS, is it possible to run bittorrent sync on it?

The CPU seem to be a Atheros AR7161 or Atheros 9344.

As far as i know there's a normal bittorrent-client for that device running dd-wrt alredy available.

Share this post


Link to post
Share on other sites

Confirmed DS1812+, installed from Synocommunity...

Seemingly unavailable:

-Giving additional users access to the application.

-Application access outside of LAN

Share this post


Link to post
Share on other sites

I can confirm, that its working on Netgear Stora MS2000 too. These are my steps with Putty:


cd /opt/
wget http://btsync.s3-website-us-east-1.amazonaws.com/btsync_arm.tar.gz
tar xzvf btsync_arm.tar.gz
./btsync

That's it. Just connect via browser and share a folder on your stora. Install Client and everything is fine.

But after a restart i have to type in again ./btsync, i dont know how to autostart, maybe someone can help.

Mfg Ironcurtain

Share this post


Link to post
Share on other sites

I can confirm that btsync works on Lenovo Iomega EZ Media & Backup Center

Steps to install it:

1. Enable SSH access by visiting: http://your-iomega-i...iagnostics.html (mark top checkbox, choose port-number and your-password, click Apply)

2. SSH to iomega (on Linux open terminal and type ssh -l root -p port-number your-iomega-ip). Warning! Your password is not the same as the one you defined through the web-page! Add 'soho' before your-password. If you had qwerty then use sohoqwerty to login.

3.

cd opt/apps

4.

wget http://btsync.s3-website-us-east-1.amazonaws.com/btsync_arm.tar.gz

5.

tar -xzvf btsync_arm.tar.gz

6.

rm btsync_arm.tar.gz

7.

nano /etc/rc.local

  • place
    (sleep 300; /opt/apps/btsync) &

    before

    exit 0


  • To save your changes press: ctrl-x, 'y' and 'enter'

8.

reboot

You're done! To test your btsync wait for ca. 10 minutes and go to http://your-iomega-ip:8888

(make sure port 8888 is open)

----------

I followed these directions for my 1tb EZ media and Backup center, however, I cannot seem to access the device via ip:8888 .

It simply says server not found. I have made sure to open the ports in the firewall, and confirmed that the change is live because I also opened the web ports for connecting outside the network and can confirm that address works.

Any ideas? The command line seemed like it did everything as instructed, the only difference i had was the address of the diagnostics page being slightly shorter. Otherwise, I'm a little stumped.

The drive is still working perfect, so no harm.. but I would love to get this really running :D

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now