Out Of Sync - No Peers Online


Recommended Posts



I've been experiencing Out of Sync on at least 7 of my 11 shares on FreeBSD x64, and 7 of my 9 shares on Linux x64.


What is the risk in the experimental build? I haven't asked yet because I would have expected it to be released here on the forums for general use, rather than one-off e-mails/PMs, if it was fit for general use.


If the risk is negligible, why not post it to the forums like typical? 


If you guys don't want to do that yet, please do send me a link for the x64 versions of FreeBSD and Linux, if you consider them stable.



Link to comment
Share on other sites

The only obvious issue I've had with experimental builds is that they aren't signed. The effect on OS X Mavericks is that I have to confirm a firewall exception every time I run it. Subjectively the performance of the one I'm running also seems a bit lower than the public version, which I attribute to additional diagnostic code being present, but this could be an illusion.

Link to comment
Share on other sites

I found a solution that worked for me, Bitorrent Sync versions between the synced computers did not match. One was 1.4.103, and a recent re-install of Windows brought me to version 1.4.106. After downgrading to 103, everything was fine. Going to stick with 103 for now, and disable auto-updating, and check myself. Way too many issues with BTSync, but when it works, it's awsome!


Link to comment
Share on other sites


I've sent a new version of experimental build (1.4.10019) to everyone requested. If it proves working - it is very likely to be included in next 1.4 public release. Looking forward for your testing results!



BitTorrent has a number of products, and this forum branch is dedicated to "BitTorrent Sync". Which product are you experiencing issues with?



It does not fit for general use, therefore I don't want to drop it to forums and be freely available for everyone who encounters it. The change touches the way how Sync operates the queue of torrents. The worst thing could happen I can think of is that Sync stucks completely and can't synchronize anything at all. In general the build has not been fully covered with QA tests, so technically it can contain some issues / degradations.

Unfortunately we don't have a freeBSD build of experimental build at the moment, so I can drop only Linux for you. I'll drop a FreeBSD build for you on Monday.

Link to comment
Share on other sites


You should get the experimental build link to your mailbox. Let us know your testing results.


Sorry this is a little off-topic but small problem: turns out I'm too new to use mailbox. I assume the Personal Messenger is the mailbox where you sent me the link. Can you activate the mailbox for me or tell me how many posts must I make before I can use it? I don't want to just post meaningless posts just to activate my mailbox but if that's the easiest way I guess I could.

Link to comment
Share on other sites

Hi - I am having the same problem. Running BTSync 1.4.106 on two Macs using LAN sync. Have been getting repeated "Out of sync" and/or "No Peers found" messages.   I -really- liked BTSync 1.3.xx - - a very useful application and everything worked fine. 


Can you please send me the experimental build to try? 


Thanks vm

Link to comment
Share on other sites

Hi RomanZ, I am having the issue described in this post. I have 3 Windows servers running BTSync with one server sharing the files and the other 2 having read only sync. One server sync's fine the other always displays Out of Sync. I have recreated share multi times and reinstalled Sync, I have also tried 2.0 alpha but the same issue "Out of Sync"issue.  


Can I please try the private release.




Link to comment
Share on other sites

Thanks RomanZ! The new build seems to work as expected and BitSync now says my files are synced.


Clicking the link "Personal Messenger" in the dropdown of my name (at the top right of this website) leads me to an error [#10226] indicating: "You are not allowed to use the private messaging system" but I mainly registered to get my Sync problem fixed which you've helped me do now so I'm not too fussed about this other issue.

Link to comment
Share on other sites

OK RomanZ. I don't know if this will help you out.

I am fairly sure that when my folder with the database that went corupt happened when I move my Mozilla profiles into that folder. Most likely the e-mail Thunderbird as it was a lot to index and well e-mail files are chaning all the time.


Bittorent sync was I am fairly sure the cause of empty folders popping up in my pop mail accounts popstate-dat(1) and can be a number. Also empty folders like nstmp.sync!

I created two copies of the same proflle one outside of the sync folder and one inside the sync folder. The one outside produces no empty folders. The one inside still does. I just delete them.


The e-mail program causes most of the locked files as when I close Thunderbird the locked file count down goes down.


Right now that folder is set to read/write. Bittorent Snyc 1.4.103

Link to comment
Share on other sites


I do have the same issues, my windows client is not syncing one folder out of 11 and says no peers.

could I get the experimental build for windows and if I have to update my linux machine as well, the ubuntu version 64bit .



Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.